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Preface 
The purpose of this book is to make TI-Nspire CAS easily and quickly accessible, especially 
for teachers and students. Many thanks to David Stoutemyer who polished the language of this 
text and made valuable suggestions for improving the original manuscript. 

Bernhard Kutzler, September 2007 & October 2008 



 

 

 

 

 



Introduction 

Question: Why should we use technology for teaching and learning mathematics?  
Answer: Because it can help students.  

Technology is for automating tasks. Instead of walking to the grocery shop, we can go 
there by car. This saves us from having to walk between our home and the shop and from 
having to carry the groceries. For some people, using a car for their shopping is a convenience 
which saves them time and energy which they can use for other activities – such as reading a 
book. For people who are physically challenged, using a car for their daily shopping may be a 
matter of survival. 

This example shows two types of technology use: Amplification and compensation. Here 
is another example: Optical instruments such as telescopes and microscopes amplify our natu-
ral eye sight so that we can see things that we cannot see otherwise. Optical instruments such 
as eye-glasses compensate poor eyesight so that people with poor eyesight can see things 
which people with normal eyesight can see without glasses. 

TI-Nspire CAS is a powerful mathematics tool suited for teaching and learning. It combi-
nes several applications under one roof: A Computer Algebra System (CAS), a graphing soft-
ware, an interactive geometry system, a spreadsheet, an interactive statistics system, a text 
editor, a data collection interface, and a programming environment.  

 
TI-Nspire™ CAS enables new approaches in teaching, learning, and understanding mathe-

matics by providing seamless integration of numeric, algebraic, graphic, geometric, and sta-
tistic capabilities enhanced with the support of data collection, programming, and text editing. 
You will find that many topics can be treated more efficiently and effectively with TI-
Nspire™ CAS than by using traditional methods or isolated products. TI-Nspire™ CAS is 
available in three compatible versions – as computer software under Windows™ and under 
Mac OS™ and as a handheld. 
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     There are also three corresponding versions of the TI-Nspire™ technology without CAS 
functionality published under the name TI-Nspire™. 

This book gets you started with TI-Nspire™ CAS by independent study. First, install TI-
Nspire™ CAS on your computer. Then, starting with the first chapter you will learn step by 
step how to use the program. Follow all instructions and examples. The text leads you through 
several mathematical topics to learn how to use TI-Nspire™ CAS. Paragraphs starting with 
the symbol � give instructions about what you should do on your computer. Hundreds of 
screen images ensure that you will not get lost on this journey. This book is written so that 
each introduction to an individual application of TI-Nspire CAS can be used independently 
(and most of them also with TI-Nspire™).  

All you need to run TI-Nspire™ CAS is a PC compatible computer with Windows 2000 
(with Service Pack 4), Windows XP (with Service Pack 2), or Windows Vista™; or a 
PowerPC, G4 or G5 with Mac OS™ X 10.4 or 10.5. 

It is assumed that you know how to use the computer and the Windows™ or Mac OS™ 
operating system. The screen shots in this book were produced from TI-Nspire™ CAS 
running on Windows XP™. If you are running TI-Nspire™ CAS with a different version of 
Windows™ or under Mac OS™, then some of the screens may appear slightly different.   

This book gets you started. A complete reference to all features is included with the 
software as online help.  

This text was written for TI-Nspire™ CAS Version 1. 4.11654. If you use a 
later version of TI-Nspire™ CAS, some of the screen images may be differ-
rent. 

Have fun reading and discovering. 

 

For users of TI-Nspire™ : 

Most parts of this book do not use the CAS component of TI-Nspire ™ CAS. Therefore you can 
use this text also with TI-Nspire™. Only part of the “Introduction to the Calculator” is CAS 
specific. All chapters that refer to “TI-Nspire” (rather than “TI-Nspire CAS”) are equally 
valid for TI-Nspire™ and TI-Nspire™ CAS.   

 

 

TI-Nspire Resources 

For resources about how to integrate TI-Nspire technology into the classroom visit the 
following websites:  

     - www.timath.com  

     - compasstech.com.au/TNSINTRO/TI-NspireCD  

     - groups.google.com/group/tinspire  

     - education.ti.com/uk (choose Online Resources from the Professional Development menu) 



Starting TI-Nspire CAS 

This text assumes that you use a factory default TI-Nspire CAS. Only then (and when you use 
WINDOWS XP) will your screen images fully match those in this book. If you just installed TI-
Nspire CAS, it is a factory default version. If you use a version of TI-Nspire CAS that was 
used by someone else earlier, we recommend that you turn it into an almost factory default 
version now. The Appendix gives instructions on how to do this. 

  
� Start TI-Nspire CAS by double clicking on the TI-Nspire CAS icon. If there is no such 

icon on your computer’s desktop or task bar, you probably will find TI-Nspire CAS on the 
Start menu or via Start>All Programs in the TI Tools folder.   

The following screen appears after a few seconds:  

 

The TI-Nspire CAS screen comprises (from top to bottom):    

• the Titlebar 
• the Menubar 
• the Command Toolbar 
• a thumbnail preview pane at the left and a work area at the right 

See what applications are available: 
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� Move the mouse pointer into the work area, and then click the right mouse button.  

= =

These are the five main applications of TI-Nspire CAS. 

� If you move the mouse button over the Insert menu button in the Command Toolbar, and 
then click the left mouse button, … 

=

… you will see two more applications to choose from. 

The Calculator application is a computer algebra system (CAS) as known from programs such 
as Derive or from handhelds such as the TI-89, TI-92, or Voyage200. 

The Graphs & Geometry application is a double application. It is a graphing application as 
known from graphing calculators such as the TI-83 or TI-84. It is also an interactive geometry 
application as known from interactive geometry programs such as Cabri Geometry. Having 
both applications integrated with each other creates a powerful “geo-graphical” environment 
which goes far beyond what the individual applications usually offer. 

The Lists & Spreadsheet application is a spreadsheet as known from programs such as Micro-
soft Excel. In addition to the usual cell-based logic it also offers column-based logic as known 
from the list editor in a TI-89, TI-92, or Voyage200. 

The Notes application is an easy-to-use word processor, which allows modes and styles parti-
cularly useful for annotating mathematical and educational work.  

The Data & Statistics application is an easy-to-use package for statistical analysis as known 
from programs such as Fathom.  

The Program Editor application is an easy-to-use and very convenient environment for writing 
and updating user defined programs and functions.  

The Data Collection application is an interface for collecting real world data. It supports 34 
sensors manufactured by Vernier.  
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The following chapters provide independent introductions to the five main applications. The 
two applications contained in the Graphs&Geometry application are treated separately.  

A major strength of TI-Nspire CAS is the “roof” that connects the individual applications. The 
first part of the “Introduction to Combining TI-Nspire CAS Applications” introduces you to 
this “roof”. The second part introduces you to the collecting of real world data. 

The Program Editor is not treated in this book. 

 

TI-Nspire CAS Teacher Edition 

There are two versions of the TI-Nspire CAS Software: the standard edition and the teacher 
edition. In this section we describe the specific features of the teacher edition. 

  
� If available, then start the TI-Nspire CAS Teacher Edition. 

 

The teacher edition offers an emulation of the handheld. You can choose between two views. 

� Open the View menu and from therein open the TI-SmartView Emulator submenu. 
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� Invoke the Handheld command. 

 

Now you see a picture of the TI-Nspire CAS handheld. You could go through the exercises of 
this book in this mode. Press a key by moving the mouse pointer above the key, and then 
clicking the left mouse button. You can enter numbers, letters, and special symbols also via 
the computer keyboard.   

� Invoke the View>TI-SmartView Emulator>Handheld + Side Screen command. 

 

In addition to the handheld you now see also an enlarged version of the handheld screen. This 
view is particularly useful when a teacher teaches students using handhelds. This view is ideal 
to show how to operate the handheld. 

� Go back to standard software view with View>Normal. 

 

 



Introduction to the Calculator 

This chapter is an introduction to using the Calculator application of TI-Nspire CAS. It will 
get you started and you will learn the routine use of this application independent of any other 
TI-Nspire applications. 

  
� Start TI-Nspire CAS. Move the mouse pointer into the work area, and then click any of 

the two mouse buttons.    

 
� Select Add Calculator by clicking the left mouse button on that text line. 

 

This changes the appearance of the work area, which now shows a blinking cursor in the upper 
left corner, a (currently dimmed) scroll bar at the right side and a counter in the lower right 
corner (currently showing “0/99”). Above the work area there are eight buttons in the 
Calculator Toolbar.    
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Start with the simple addition of two rational numbers.  

� Input through the keyboard:   1/2+1/3 

  
As you type them the symbols appear on the screen. 

� End the input with the ‘Enter’-key E¿F. 

  
The entry is displayed in “2-dimensional” output format, as opposed to the “1-dimensional” or 
linear input format that was used for entering. The result of this computation is computed 
automatically and displayed at the right end of the Calculator window. Entry and answer 
together make the first history pair. The blinking cursor below the entry indicates that the 
Calculator is ready to accept the next input. The counter in the lower right corner changed to 
“1/99” for “1 history pair out of 99”. (99 is the maximum number of history pairs a Calculator 
page can store. If you add expressions beyond that, the oldest pair(s) are discarded. 

  
Repeat the last input with an intentional typographical error: 

� 1/2+1’3  E¿F 

  
An error message is displayed when the Calculator cannot understand an input string.  

� Quit the error message by clicking E|lh|F or using the ‘Enter’-key E¿F. 

  
The faulty input remains in input mode (though displayed 2-dimensionally where applicable) 
with the cursor blinking at the position where the problem was detected. This gives you a 
chance to correct the input. 

� Delete the digit ‘3’ right of the cursor with the computer keyboard’s EabiF key or by 

using the Command Toolbar’s Delete button . 
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� Delete the two symbols left of the cursor using the backspace key E‹|F two times. 

  
An alternative to entering a fraction as a linear input string is using the “2-dimensional” frac-
tion template, which is similar to what equation editors offer. It is particularly useful for 
entering more complicated fractions.  

� Move the mouse pointer above the fifth button from the right in the Command Toolbar. 

  
Observe the tool tip saying  Shows the Math Templates  , which appears under the mouse 
pointer for about 3-4 seconds. Such tool tips are available for all buttons. 

� With the mouse pointer pointing on the button , click the left mouse button to open the 
Math Templates Toolbar. 

  
The Math Templates Toolbar offers templates for many standard mathematical expressions 
such as fractions, radicals, logarithms, matrices, vectors, limits, derivatives, integrals, etc.  

� Insert a fraction template at the current cursor position by clicking on the fraction template 
in the upper left corner. 

 = =

The cursor is positioned in the dashed box above the fraction bar so that you can input the 
numerator.  

� Type ‘3+4’. Use the tab key EˆF to move the cursor into the denominator input field. 

 = =

� Type ‘5’, and then conclude the input with E¿F. 

 =

� 

Enter the next expression, 24 . There are several methods to enter the square root symbol, 
one of them is to use the Math Templates Toolbar.1 

                                                        
1 Alternative methods include entering the square root of 24 via the keyboard as SQRT(24) or 24^(1/2). 
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� Display the Math Templates Toolbar by clicking on . Enter 24  as follows:  

Click on the Math Template Toolbar button . (You need to click twice – one time to 
select the button, one more time to use it.) Type: 24 

 = =

� Conclude the input with E¿F. 

 =

This is different from what many calculators would produce. A mathematician once asked: 
“How do you recognize a mathematician?” and suggested the following answer: “A mathe-

matician considers 2 6⋅  a beautiful result.” Most students strive to replace such an expres-
sion by the corresponding floating point approximation 4.8989…. As explained later TI-
Nspire CAS can do this as well.  

Any expression in the history area can be highlighted then auto-pasted into the entry line to be 
used to help build a new entry.  

Press the upward key to shift the highlighting from the entry line to the last answer. Pressing 
the upward key again moves the highlighting back in the history area: from the last answer to 
the last entry, then to the penultimate answer, then to the penultimate entry, and so on. 

� Use the up arrow key E½F. E½F 

 =  
� E½F Use the down arrow key E¼F. 

 =  
� Auto-paste the highlighted expression into the entry line with E¿F.  

  
Alternatively one can highlight any expression (or a part thereof) using the standard Windows 
technique with the mouse. (Click on one end of the string you want to select; hold the mouse 
button, and then drag the mouse pointer to the other end of the string.) You can also use the 
standard Windows hotkeys for copy (E`íêäF+E`F) and paste (E`íêäF+EsF). 
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The symbols on the Calculator Toolbar’s second button, , indicate a conversion from an 
exact number to a floating point number (which may be an approximation). 

 

� Open the Number menu by clicking the button  with the left mouse button.  

  
This menu offers several commands. The first command, Convert to Decimal, seems appro-
priate for obtaining a decimal approximation. Try it: 

� Move the mouse pointer into the text line Convert to Decimal. 

  
� Invoke the command by clicking on it with the left mouse button. 

  
� Conclude the input with E¿F.  

  
This is a six digit approximation. For a different number of digits use the File>Settings> 

Document Settings command: 

� Open the File menu, from therein open the Settings submenu, and then choose the 
Document Settings command.  
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The first input field in this dialog, Display Digits, is set to Float6, which stands for “floating 
point number with six digits”. 

� Open the selection menu of the Display Digits input field by clicking the down arrow 

button  at the right end of the input field.  

  
� Change to ten digits: Move the mouse pointer into the text line Float10, … 

  
� … and then click on it. 

  
� Apply the new setting to the current document by exiting the dialog with E|lh|F. 

Test the change by repeating the last example: 

� Highlight the last entry by pressing E½F twice.  

  
Try an alternative to auto-pasting with the ‘Enter’-key: 

� Copy the highlighted expression into the Windows clipboard with E`íêäF+E`F.  
Return control to the entry line with Ebp`F, and then paste the clipboard contents with 

E`íêäF+EsF. Conclude the input with E¿F. 

  
This is a ten digit approximation of the square root of 24.  
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Enter 24  again, this time using the built-in function sqrt: 

� Type:   sqr 

  
As you type these letters, they appear in italics. TI-Nspire CAS displays variables in italics, 
i.e. the input string entered so far is interpreted as a variable named sqr. 

� Type:   t 

  
Once the letter ‘t’ is added, TI-Nspire CAS recognizes the input string as the name of the 
built-in function sqrt and does not display it in italics any longer. This feature helps avoiding 
name conflicts.  

� Type an opening parenthesis:   ( 

  
A matching closing parenthesis automatically is inserted after the cursor.  

� Type:   24 

  
Now you can optionally type a closing parenthesis, it makes no difference. 

� Conclude the input with E¿F. 

  
See what happens if you apply the Convert to Decimal command from the Number menu 
without having an expression in the entry line: 

� Open the Number menu ( ), and then click on the Convert to Decimal command. 

  
The string ‘Ans’ left of the black triangle is a reference to the most recent answer (which is 

2 6⋅ ). 

� Conclude the input. 

  
When this entry is displayed in the history pair, the first argument, ‘Ans’, got replaced by the 
expression it stood for. Using ‘Ans’ indirectly such as in the previous example or directly by 
typing it is a standard technique for using, in the next computation, the expression that was 
just entered or produced. 

A history pair can be deleted by highlighting the entry or the answer, and then using the key-

board’s EabiF key or the Command Toolbar’s button . 
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� Highlight the most recent answer. 

  
� Delete this history pair with the keyboard’s EabiF key. 

  
A virtual version of the handheld’s keypad is an alternative to the computer keyboard. 

� Display the handheld’s keypad by clicking on the Command Toolbar button  (or by 
using the View>Keypad command). 

  
This keypad is resizable and floatable, hence it can be placed wherever wanted or needed. 
Clicking on any of these keys is equivalent to making the respective input via the computer 
keyboard. The keypad offers some keys that are not on a computer keyboard. Therefore it can 
serve as a source for “hot keys” for entries that are more difficult to enter using a computer 
keyboard. 

� Click on the handheld keypad’s ‘Enter’-key ·. 

  
This repeated the last example. Note that no expression was entered. If there is no expression 
in the entry line, TI-Nspire CAS uses the most recent entry. 

The keypad’s ‘Enter’-key shows the approximation symbol ≈ in blue color above the word 
‘Enter’. This indicates that this function of the key can be accessed via the keypad’s blue 
control key /. 

� Click on the keypad’s control key / followed by the ‘Enter’-key ·. 
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This produces the same result as the Convert to Decimal command. The key combination 
E`íêäF+E¿F works the same on the computer keyboard. 

� Turn off the keypad by clicking on  in its upper right corner.  
Using the computer keyboard type:   1/3 E`íêäF+E¿F 

  
� 

TI-Nspire CAS uses two types of numbers: exact (symbolic) numbers and floating point num-
bers. Exact numbers are integers, symbolic constants such as π and e, and expressions built 

from these, such as 3+4, 1/2, 5 , sin( / 2)π . Floating point numbers are numbers with a deci-

mal point such as 1., 2.5, and 0.33333, or ones that have an E representing ‘*10^’. 

While E`íêäF+E¿F always gives floating point results, the behavior of E¿F is determined by 
a mode that is controlled via the Auto or Approximate input field in the Document Settings 
dialog.  

=

The default mode is Auto, in which E¿F gives exact (symbolic) results if an algorithm for 
computing the exact result is implemented and if all numbers in the entry are exact numbers. If 
at least one number in the entry is a floating point number, the result will be a floating point 
number or, if the result is non-numeric, corresponding coefficients will be floating point num-
bers. This yields another method to enforce a floating point (approximate) result: Simply add a 
decimal point to an integer in the input – or add a floating point zero (+0.) or multiply with a 
floating point one (*1.).  

� Enter: 1+1/2  
Enter: 1.+1/2 

  
In Approximate mode E¿F always gives floating point results. In Exact mode E¿F always 
gives exact answers or echoes the input if no exact answer can be given. This is where the 
difference lies: While Exact mode will not give any result when a symbolic result cannot be 
found, such as when solving the equation 2sin( ) 0x x− = , Auto mode in this case will try to 

find an approximate answer. If it does not find an approximate 
answer either, the input is echoed. The mode is displayed at the 
right end of the command toolbar, see AUTO between RAD (mode 
for angles in radian) and REAL (mode for real numbers). 
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� 

Symbolic constants such as π and e can be entered via the Symbol Toolbar. 

� Display the Symbol Toolbar by clicking the Command Toolbar’s button . 

  

� Input π by clicking on  in the upper left corner of the Symbol Toolbar. 

  
� Type a plus (‘+’) for addition, and then input the number e: display the Symbol Toolbar, 

and then use  (which is next to ). Conclude the input. 

  
� 

TI-Nspire CAS can handle very large numbers. 

� Enter 123 factorial:   123! 

  
The result is larger than the width of this application window. Therefore the answer appears 
cut off, as is indicated by the small black triangle just before the window’s right end. 

Decompose this number into prime factors. This is done using the built-in factor function: 

� Auto-paste the factor function into the entry line by opening the Number menu ( ), and 
then clicking on the Factor command (in the sequel denoted as Number>Factor). 

  
The factor function name comes with an opening and a closing parenthesis with the cursor in 
between waiting for an argument to be inserted. You could highlight, and then auto-paste the 
last answer – or the previous entry, or any other expression. Enter a reference to the last 
answer: 

� Type:   ans 

  
� Conclude the input by pressing E¿F. 

  
Proceed as follows to see the rest of the answer: 

� Highlight the answer. 
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There are three methods to remove the highlighting without highlighting a different expression 
or moving back into the entry line: Clicking anywhere on the highlighted expression removes 
the highlighting and puts the cursor at the position of the mouse pointer. The left arrow key 
E‹F removes the highlighting and puts the cursor at the left end of the expression. The right 
arrow key EÃF removes the highlighting and puts the cursor at the right end of the expression. 

� Put the cursor at the right end of the expression with EÃF. 

  
Use the left and right arrow keys to move the cursor character by character. Use EeçãÉF and 
EbåÇF for the left and right end of the expression. 

� Use the left arrow key to move the cursor directly in front of the factor 53 (so that it is 
between the multiplication symbol and the number 53).  

 =

Three more applications of the left arrow key will cause a jump of the expression by half of 
the width of the work area: 

� E‹F=E‹F=E‹F 

  
The fastest method to bring cursor control back into the entry line is the escape key Ebp`F. 

� Move control into the entry line with Ebp`F. 

  
To find out how many digits the factorial of 123 has, compute an approximation: 

� 123!  E`íêäF+E¿F 

  
The answer is displayed in scientific notation. Because the count of whole digits is one more 
than the power of 10, the number has 205+1 = 206 digits. 

When using TI-Nspire CAS in a classroom for demonstration purposes, for example with a 
projector, it may be useful to use a larger font. For this, TI-Nspire CAS offers a special mode. 

� Open the View menu. 
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� Activate the Presentation command. 

  
The preview pane disappeared and the expressions are displayed in a larger font. There is also 
a Handheld Screen view in which the screen looks similar to the screen on a handheld. 

This command is a toggle switch. Apply it again to switch back to standard viewing mode: 

� Invoke View>Presentation. 

  
� 

Before starting with a group of examples on algebra and equation solving, delete all history 
pairs. This can be achieved quickly with the Clear History command from the Calculator’s 
Actions menu. 

� Open the Calculator’s Actions menu by clicking on .  
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� Activate the Clear History command by clicking the command name.  

  
� 

Enter the expression 
3 4

x x+ : 

� Type:  x/3+x/4  

  
You could have used the fraction template, but for simple fractions such as these the linear 
input using the division operator (denoted by the forward slash character) is faster. 

� Conclude the input.  

  
Unlike ordinary calculators, TI-Nspire CAS can perform non-numeric (symbolic, algebraic) 

computations such as simplifying 
3 4

x x+  into 
7

12

x
. The ability to perform such algebraic trans-

formations is the reason why this technology is called “computer algebra”. 

Enter the expression sin( )x . Start as follows: 

� Type:  sin  

 =  
TI-Nspire CAS recognizes the string ‘sin’ as the name of the built-in sine function, therefore it 
is not displayed in italics. Intentionally input the argument x without parentheses around it: 

� Type:  x  

  
The string sinx is displayed in italics. This indicates that TI-Nspire CAS considers this a four 
letter variable name. Add the sine of x, this times with parentheses around the argument: 

� Enter:  +sin(x)  
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Entering the sine of x without the parenthesis around the argument x is a frequent error, which 
can cause “strange” errors, such as strange results when solving an equation or strange deriva-
tives or indefinite integrals. The way TI-Nspires distinguishes variables from built-in or user-
defined names by displaying them differently helps to avoid errors and can help locate causes 
of errors. 

� 

Enter the equation 2 0a x b x c⋅ + ⋅ + = : (On a computer keyboard multiplication is entered 
using the asterisk key EGF. TI-Nspire displays multiplication as a centered dot.) 

� Type:  a*x  

  
Make sure to write a multiplication symbol between a and x, as otherwise your input will be 
interpreted as the two letter variable ax. 

� Type:  ^2 

  
TI-Nspire CAS displays the exponent as a superscript like equation editors do. When you type 
the exponentiation operator ^ it goes into exponentiation/superscript mode. (An alternative is 
the exponentiation template from the Math Templates Toolbar.) 

� Type:  +b 

  
Oops! The new input, ‘+b’, should be on the same level as ‘a*x’, but it has become part of the 
exponent. Once TI-Nspire CAS is in exponentation/superscript mode, this mode remains 
active until it is switched off with the right arrow key or the tab key. 

� Delete the last two characters with two applications of the backspace key E‹|F. 

  
� Exit exponentiation/superscript mode with EˆF or EÃF. 

  
Observe the difference: Now the red dotted line is below a and x and the blinking cursor 
reaches all the way down to it. 

� Enter (= type, and then conclude the input):  +b*x+c=0 

  
Solve this equation using the Solve command from the Algebra menu: 

� Open the Algebra menu by clicking on . 
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� Invoke the Solve command. 

  
A copy of the solve function name with a pair of parenthesis and the cursor positioned in 
between was auto-pasted into the entry line. 

� Insert the equation 2 0a x b x c⋅ + ⋅ + = as the argument of solve by highlighting it with 
E½F, and then auto-pasting it with E¿F. 

  
� Conclude the input. 

  
This produced a ‘Too few arguments’ error message that indicates that you need to also 
specify, as a second argument, the variable with respect to which the equation should be 
solved. 

� Quit the error message by clicking on E|lh|F or pressing E¿F. 

  
Add variable x as a second argument: 

� Move the cursor between 0 and the closing parenthesis, and then type:   ,x 

 =  
Even if you used the backspace key E‹|F rather than the left arrow key E‹F, the closing 
parenthesis did not disappear. 

� Conclude the history pair. 

  
Test the candidate solutions by expanding 1 2( )( )x x x x− −  with 1x  and 2x  being the two 

solutions.  

� Type:   (x- 
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1x  is the first solution, which currently is not available as an isolated expression, it only 

appears as a subexpression within the solution that was just generated. Highlight the respect-
tive subexpression so that you can auto-paste it. This can be achieved with the arrow keys or 
the mouse. Use the arrow keys for 1x , and then the mouse for 2x . 

� Highlight the last answer with E½F.= Remove the highlighting with E‹F. 

 =  
� Move the cursor two characters to the right. Hold the shift key EŸF, and then use EÃF. 

 =  
Now the first solution, 1x , is highlighted. 

� Auto-paste this subexpression with E¿F. 

  
� Move the cursor past the closing parenthesis with EÃF (or type a closing parenthesis). 

Type:   *(x- 

  
Next use the mouse technique to select 2x : 

� Move the mouse pointer above the left end of the fraction bar. 
      Click and hold the left mouse button. 

 =  
� With the left mouse button depressed, move the mouse slightly to the right. 

 = =

It was that easy because you started with the mouse pointer pointing at the “shallowest” opera-
tor, which, in this case, is the fraction bar. What if the mouse pointer was too high or too low? 
It works too, you just need more movements with the mouse. 
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� Remove the highlighting by clicking outside the highlighted area. Move the mouse pointer 
somewhere on the numerator; for example, let it point at the number 4.       
     Click and hold the left mouse button. 

 =  
� With the left mouse button held down, move the mouse slightly to the right. 

 =

� With the left mouse button still depressed, move the mouse down into the “area” of the 
denominator. 

 =

Now the second solution, 2x , is highlighted. 

� Auto-paste this subexpression with E¿F. 

  
� Conclude the input. 

  
TI-Nspire CAS rewrites the expression by putting it over a common denominator. To expand 
the two factors in the numerator, apply the Expand command from the Algebra menu: 

� Invoke the Algebra>Expand command. Apply it to the last answer by typing:  ans 

 =  
� Conclude the input. 
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The warning message in the bottom line of the calculator window is cut off. If you would 
make the window wider you could see the whole message, it ends ‘… of the input’. This mess-

age is displayed, because an 
a

a
 was cancelled to 1 when forming the 2x  term, and 

2a x

a

⋅
 can 

be regarded as “undefined” when a=0, whereas 2x  is defined for all values of a. Such an 
enlarged domain of definition for a sub-expression is generally harmless or beneficial, but 
some people want to be warned about it. A reduced domain of definition would be of greater 
concern. 

Obtain the left hand side of the original equation by multiplying this answer with a:   

� Type the multiplication operator * without a first argument. 

  
TI-Nspire CAS always tries to make sense to your input. An infix binary operator such as the 
multiply operator has to be entered as: “first argument * second argument”. If it is entered 
without a first argument, such as above, TI-Nspire CAS automatically inserts a reference to 
the last answer, ans, as a first argument. 

� Type:   a 

  
� Conclude the input. 

  
� 

The next example is the simple equation 3 1 0x − = . 

� Enter:   x^3-1=0   (Intentionally “forget” to exit the exponentiation/superscript mode.) 

  
� Quit the error message by clicking on E|lh|F. 

  
In some cases, such as this, quitting the error message produces a history pair with the faulty 
entry and the error message as a “result”. You could delete this history pair, but then you 
would have to start again making the entire input. It is more convenient in this case to use the 

Command Toolbar’s Undo button . The Undo command is also available from the Edit 
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menu. It behaves as in most Windows programs, i.e. it undoes the most recent step – in this 
case the application of the ‘Enter’-key for entering the faulty input string. 

� Undo the last keyboard input by clicking on . 

  
Now you can edit the input: 

� Apply the backspace key E‹|F. 

  
This did not delete any character, but highlighted the entire exponent. Another application of 
the backspace key will delete the entire exponent. 

� Apply E‹|F, and then type:   ^3 

  
� Exit exponentiation mode with EˆF. Type:   -1=0 

 =  
� Conclude the input. 

  
Solve this equation. An alternative to auto-pasting the solve function from the Algebra menu 
is to type the function name. Remember to enter the variable as a second argument: 

� Enter:   solve(ans,x) 

  
The solve function computes only the real solution. To obtain also the non-real solutions, you 
need to use a different function. 

� Open the Algebra menu. 
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The first five options in the Algebra menu, Solve, …, Numerical Solve, are commands, all of 
which auto-paste the respective function names. The next six options, Polynomial Tools, …, 
Extract, are entries into submenus as is indicated by the small black triangles appearing to the 
right of these names. One of these submenus, Complex, is what you need for obtaining non-
real solutions. The last option, Finance Solver, starts a wizard that helps you solve financial 
mathematics problems. 

� Open the Complex submenu by clicking its name. 

  
� Click on Solve to invoke the Algebra>Complex>Solve command. 

  
The respective function name, cSolve, is composed of the name of the solve function, prece-
ded by the letter ‘c’ for ‘complex’. When you enter names, TI-Nspire CAS does not distin-
guish between upper and lower case letters. For the display, TI-Nspire CAS uses a built-in 
standard. In this standard function names start with lower case letters. If a function name is 
composed of several words, such as ‘c(omplex) solve’, each new word or abbreviation of it – 
except for the first – will start with an upper case letter such as in ‘cSolve’ (the so called 
“camel case”). This makes reading and understanding function names easier. 

� Auto-paste the equation after highlighting it, and then type:   ,x 

 =  
� Conclude the input. 

  
Now TI-Nspire CAS yields all three solutions. One real and two non-real. The two non-real 
solutions are displayed in rectangular format, which is the default. The polar format is avail-
able as an alternative. It can be chosen from the Document Settings dialog. 

� Invoke the File>Settings>Document Settings command. Open the pull-down selection 

menu of the Real or Complex Format input field by clicking its down arrow button . 

  
� Click on Polar. Apply the change to this document by leaving the dialog with E|lh|F. 

Repeat the last example … 
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� … simply by pressing the ‘Enter’-key E¿F without any new input. 

  
� 

The factor function is a “relative” of the solve function. Apply it to the same example after 
locating it in the Catalog, which is another handy method for locating and accessing functions 
and commands: 

� Open the Catalog by clicking on the Command Toolbar’s button  or by using the 
Tools>Catalog command. 

  
Make sure the first tab is active, i.e. the tab with number 1 on it is white and all others are 
gray. If not, click on the first tab to make it active. 

In the Catalog, all built-in functions and commands are listed in alphabetical order. Type a 
letter to get to the respective section. 

� Go to the section of functions and commands starting with ‘F’ by pressing EcF. 

  
The first entry beginning with ‘F’ is the factorization function factor. The last line in the dia-
log shows how to use this function. The text ‘factor(Expr[,Var])’ is like a “mini online help”. It 
indicates that factor can be used either with one or with two arguments. The first argument is 
an expression (Expr) and is compulsory. The second argument is a variable (Var) and is optio-
nal. Optionality is indicated – as is usual in computing literature – by writing it between 
square brackets. 

� Auto-paste the function name by clicking on the text line ‘factor(‘. 
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While the solve function needs an equation as the first argument, the factor function can be 
applied to either the expression 3 1x −  or the equation 3 1 0x − = . If you feed it with an equa-
tion, both sides of the equation will be factored. Apply it to the expression, not the equation. 
You could highlight the left hand side of the equation, and then auto-paste it into the entry 
line. However, the input is so short, that retyping it may be quicker. 

� Enter:   x^3-1 

  
To allow for finding factors with non-real coefficients, you need the function cFactor. The 
function name could be copied from the Algebra>Complex submenu, but it is faster to insert 
the letter ‘c’ before the previous input string. 

� Highlight the last entry. Auto-paste it into the entry line. 

 =  
� Move the cursor to the left end of the expression. 

  
� Type:   c 

  
� Conclude the input. 

  
The result is not any different from the previous factorization over the real numbers. What 
went wrong? 

Remember that the “mini online help” for the factor function listed a variable as an optional 
second argument. Use it: 

� Auto-paste the last entry, and then add variable x as the second argument. 

  
� Conclude the input. 

  
When factor or cFactor are used without a second argument, the result won’t contain any new 
irrational coefficients. Specifying the variable as a second argument allows factors with 
irrational coefficients such as in this example. 

� 

Insert another Calculator page: 
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� Invoke the Insert>Calculator command. 

  
This emptied the Calculator work area. What happened to the expressions? Note the change in 
the preview pane on the left. So far, the preview pane showed one page that was a miniature 
version of the Calculator work area. All changes you did in the Calculator work area caused 
respective changes in the mini-page. Now there is a second mini-page, which is empty. It is a 
miniature of the empty Calculator work area that you see right now.  

� In the preview pane click on the upper page. 

  
This brought back the “old” calculator work area content – so it is still there! 

With TI-Nspire CAS you create documents. Each document is a collection of problems. 
Currently there is only one problem in the document, named Problem1. 

=

Each problem is a collection of pages. Currently there are two pages in Problem1, both of 
them are Calculator pages. Pages also can carry other applications (Graphs&Geometry, Lists& 
Spreadsheets, Notes, Data&Statistics). Pages can be split into up to four subpages using the 
Insert>Layout command. Each subpage can carry its own application. More on this is 
explained in the “Introduction to Combining TI-Nspire CAS Applications”. 

Pages can be added to a problem. The Insert>Page command adds an empty page. The Insert> 

Calculator command adds a page connected to the Calculator application. The Insert>Graphs& 

Geometry command adds a page connected to the Graphs&Geometry application, etc. Pro-
blems can be added using the Insert>Problem command. 
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User definitions such as storing an expression in a variable apply to all pages of a problem, but 
they don’t apply to any other problem. 

There is a decimal number in the upper right corner of the application window, above the 
work area and just right of the toolbar. Currently the number is ‘1.1’: 

 
� In the preview pane click on the lower page. 

  
Now the number is ‘1.2’. It is composed of the problem number and the page number, i.e. 
‘1.2’ refers the second page of Problem1. 

In the preview pane problems and pages can be deleted, moved, copied, etc. using standard 
Windows techniques. The document can be saved under a name using the File>Save as 
command. 

� 

Make sure that the second (empty) page is active. Enter 1, and then compute the cosine of 1 
using a reference to the last answer: 

� In the preview pane click on the second page.  
Then click into the Calculator work area to bring keyboard control (focus) into it. 
Enter:   1 
Enter:   cos(ans) 

  
The expression cos(1) remains unchanged, because there is no “better” (e.g. shorter) symbolic 
representation of it. It could be approximated by a floating point number, but you used E¿F to 
obtain an exact result. 

Note that you don’t see that you entered ‘cos(ans)’. In fact, the history pair would be the same 
if you had entered ‘cos(1)’. However, when you apply the ‘Enter’-key E¿F again, these two 
entries make a difference: 

� Press E¿F. 

  
Remember that the ‘Enter’-key repeats the last entry. Because the last entry was ‘cos(ans)’ 
(and not ‘cos(1)’), the application of the cosine function got iterated. If your previous entry 
would have been ‘cos(1)’, you would only see another copy of ‘cos(1)’. Do it again: 

� Press E¿F. 
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Starting with an initial value, then entering an expression using the most recent answer, and 
then repeatedly hitting the ‘Enter’-key is an easy way to produce an iteration. Try the same 
example, but this time start with a floating point 1 (rather than an integer 1), so that approxi-
mate answers are enforced without having to use E`íêäF+E¿F. 

� Enter:   1. 
Enter:   cos(ans) 

E¿FE¿F 

  
Observe that while on the right the results are in Float6 format with six digits, the arguments 
of the cosine function invokation on the left have 14 digits. Internally all floating point arith-
metic is done with 14 digits. The setting in the Document Settings dialog (which currently is 
Float6) is used only for displaying answers. 

� Repeatedly press the ‘Enter’-key until the result does not change any more.  

  
This example demonstrates the difference between internal arithmetic and display. The result 
appears not to change any more, because we see only the leading six digits. But the display of 
the result as an argument in the next entry shows its full length and you can see that the num-
bers still change. 

You could continue pressing E¿F until the argument of the cosine function does not change 
any further … 

=

… or, as is the case here, toggles between two values. 

The example that you just finished is the application of the fixed-point method for computing 
a fixed point of a function. You produced an approximation of the number x, for which 
cos(x)=x. This method converges under certain conditions. (The easiest way to find out is to 
try it.) The method also can be used to compute a zero of a function: To find an approximation 
of a zero of a function f, i.e. x, such that f(x)=0, you can apply the above fixed-point method to 
g(x):=f(x)-x. 

� 
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In combination with the colon separator, which is used to make more than one input in one 
line, you can use the iteration method to consecutively generate integer squares as follows: 

� Enter:   i:=1 
Enter:   i:=i+1 : i^2 

E¿FE¿F 

  
� 

Conclude this first round of examples by exiting TI-Nspire CAS: 

� Exit TI-Nspire CAS using the File>Exit command. 

  
TI-Nspire CAS asks if the yet unnamed document should be saved. 

� To exit without saving click on E|kç|F. 

 



Introduction to Graphing 

This chapter is an introduction to the Graphing application of TI-Nspire, which is part of the 
Graphs&Geometry application. This text will get you started and you will learn the routine use 
of this application independent of any other TI-Nspire applications. 

  
� Start TI-Nspire. Move the mouse pointer into the work area, and then click any of the two 

mouse buttons.    

 
� Select Add Graphs&Geometry by clicking the left mouse button on that text line. 

 

The work area now shows a coordinate system. At its lower end there is an entry line for the 
function editor with the input cursor blinking next to an undefined function f1. Above the 
work area there are ten buttons in the Graphs&Geometry Toolbar.    

The plot range is determined by the size of the graphing window. The horizontal axis ranges 
from -10 to 10. The vertical axis is chosen such that the units are equally long on both axes 
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and a circle will be circular. The scale factor, it is 0.5 for both axes in the above picture, is 
chosen such that the distance between two tick marks is “neither too small nor too big”.  

Plot the graph of the function 2y x= . The blinking cursor is next to a proposed function name 

f1, so use f1 as a name for this function:   

� Type:   x^2 

  
Typing the exponentiation symbol switched on exponentiation/superscript mode, therefore 
you see a raised-up exponent. Learn more about entering mathematical expressions in the 
“Introduction to the Calculator”. 

� Conclude the input with the ‘Enter’-key E¿F. 

  

You see the graph of the function 2y x=  and a label ‘f1(x)=x²’ next to it. The blinking cursor 

in the entry line now is ready for a new function f2. 

� Move the mouse pointer into an empty area. Click and hold the left mouse button, and 
then drag the mouse down and to the left. 

 =  
This changes the window settings.  

There are several methods to change the window settings. You can find most of them in the 

Window menu that you can open via the button  in the Graphs&Geometry toolbar. 
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� Open the Window menu by clicking on . Point at the text Window Settings, and then 
click the left mouse button to activate this command. 

 == =

In this menu you can choose ranges for both axes. You can leave the scale factors on 
automatic (default setting Auto) or enter a value. Leave everything unchanged: 

� Exit the menu with Ebp`F. 

You can change the scale factor easily using the mouse: 

� Move the mouse pointer to one of the tick marks on the positive vertical axis until the 
pointer has the shape of a hand, the text ‘Axes’ appears, and all tick marks are blinking 
without the axes being thick. 

 êáÖÜíW== = ïêçåÖW=  

� Click and hold the left mouse button (= grab the tick mark), and then move the mouse 
pointer down (= drag the tick mark down). 

 =  
This changed the scale factor of both axes. If you want to change the scale of only one axis, 
use this method together with the shift key EŸF. 
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� While holding the shift key EŸF, grab a vertical tick mark and drag it down.  

 =  
Resume to standard axes. An appropriate command for this can be found in the Window menu. 

� Open the Window menu. Invoke the Zoom – Standard command. 

 ========= =

� 

Make more experiments with this graph: 

� Move the mouse pointer over the curve. 

 =

The graph starts blinking and the text ‘graph f1’ is displayed to indicate that you point at the 
graph. The mouse pointer now has the shape of a diagonal dash with a double-headed arrow 
perpendicular to it. Find out what this is good for: 

� When you see this shape, click and hold the left mouse button, and then drag the mouse 
pointer down. 

 = =
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This changed the curve – and with it the label, i.e. the algebraic expression belonging to the 
graph.  

� Move the mouse pointer near the origin. 

 =

The mouse pointer takes the shape of a four-headed arrow. This indicates that now you can 
translate the curve. The symbol e next to the text ‘graph f1’ indicates that the pointer 
currently points not only at the graph but also at another object. (In the above example it is the 
horizontal axis.) By pressing the tabulator key you can switch to the other object(s).  

� When you see the four-headed arrow, click and hold the left mouse button, and then drag 
the mouse pointer up and to the left. Finally release the left mouse button. 

 = =

Undo the translation by clicking on the Command Toolbar’s Undo button  or by invoking 
the Undo command from the Menubar’s Edit menu: 

� Undo the last step with . 

 =

Look at the function entry line at the bottom. Currently it has a gray background and there is 
no cursor blinking. This is, because currently the input control is in the graphing area.  

� Move control into the entry line by clicking into it or by applying the tab-key EˆF. 

 =

The double up arrow at the entry line’s right end is for displaying the entry line’s history.  
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� Click the double up arrow . 

 =

The expression defining f1 has changed here too. f1 is in bold, because it is user defined. f2 is 
in italics, because it is (still) undefined. The double down arrow at the right end of the entry 
line is for switching off the history display. 

� Click the double down arrow . 

 =

The entry line can be hidden. The respective command is in the View menu. 

� Open the View menu by clicking . Invoke the Hide Entry Line command. 

 ==== =

Note from the menu text that E`íêäF+EdF is a hot key for this useful command.  

� 

The label moved with the curve because the label is attached to the curve. Grab the label, and 
then move it to some other position: 

� Move the mouse pointer over the label. 

 =

The mouse pointer turns into a hand, the label blinks, and the text ‘label’ is shown.  
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� Click and hold the left mouse button (= grab the label), and then move it up. Release the 
button. 

 = =

See what you can do with the curve: 

� Move the mouse pointer above the curve until it blinks.  
   Click the right mouse button. 

 = =

As is usual in Windows programs, a context sensitive pop-up menu displays with options for 
the selected object. Among other options, there is a Delete command, a Hide/Show switch, and 
a Recent submenu. You can recognize submenu opportunities by the small solid triangle at the 
right end of a listing.  

� Invoke the Attributes command. 

 =

A graphical menu appears with options for graph attributes. The first option is surrounded by a 
black square. There is a small black triangle to its right, and a description of the current setting 
is displayed under the menu.  (1/3) Line weight is thin  means that ‘thin’ is the first out of three 
choices for line weight. 
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� Move to the second choice for line weight by clicking on the small black triangle (or by 
using EÃF). 

 =

Now the graph is thicker, the text has changed to  (2/3) Line weight is medium , and there is now 
also a small black triangle left of the first menu. Clicking on the triangle on the left would 
switch back to the first choice, i.e. to a thin line. See what else is there:  

� Move to the third choice by clicking on the triangle on the right. 

 =

The graph has become even thicker, the text has changed to  (3/3) Line weight is thick , and 
there is no small black triangle on the right any more.  

� Switch back to the medium line with E‹F. Move to the second menu option with E¼F. 

 = =

The second option allows to change the line style. The three options are ‘continuous’, ‘dotted’, 
and ‘dashed’.  
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� Change to a dashed line. Make both changes permanent with E¿F. 

 = =

If you exit the graphical menu with the ‘Enter’-key, the changes remain. If you exit it with 
Ebp`F, the graph goes back to as it was before you opened the menu. Therefore, the changes 
you see are all previews until you exit the menu with ‘Enter’ or by clicking outside the menu. 

� 

When using TI-Nspire in a classroom for demonstration purposes, for example with a pro-
jector, it may be useful to use larger fonts. For this, TI-Nspire offers a special mode. 

� Open the View menu. 

  
� Invoke the Presentation command. 

  
The preview pane disappeared and the expressions are displayed in a larger font. There is also 
a Handheld Screen view in which the screen looks similar to the screen on a handheld. 

This command is a toggle switch. Apply it again to switch back to normal viewing mode. 
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� Invoke View>Presentation View. 

  
� 

Currently there is an algebraic and a graphic representation on the screen. How about a 
numeric representation? Display a function table:  

� Open the View menu. Choose the Add Function Table command. 

 ============== =

Note from the menu text that E`íêäF+EqF is a hot key for this command. 

Now the work area is split in two halves. The left half is for the graphic, the right half is for 
the table. The application toolbar has changed. What you see now is the toolbar belonging to 
the List&Spreadsheet application, as the function table is a special instance of this application. 
Learn more about this application in the “Introduction to Lists & Spreadsheet”. 

The table has two columns. The first column contains values of x (starting from zero and 
growing in steps of one); the second column contains the respective function values. Make the 
table narrower, so that there is more room for the graph. 

� Move the mouse pointer to the line that splits the two application windows until it takes 
the shape of a blue vertical bar with a two-headed arrow perpendicular to it. 

 = =
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� Click and hold the left mouse button, and then drag it to the right until the table has the 
appropriate size. Release the mouse button. 

 = =

Change the table settings: 

� Make sure that you see the Lists&Spreadsheet Toolbar. If not, click into the table to make 

the table window active. Open the Function Table menu by clicking on .  
Choose the Edit Function Table Settings command. 

 = =

The current Table Start value is highlighted, so this is where any keyboard input will currently 
go. 

� Change the Table Start value to:   -1    Move into the next field with EˆF. 
      Change the Table Step value to:   0.2 

 = =

� Conclude the input by leaving the dialog with E|lh|F.  

 =
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Change the curve again – and observe how the table values change with it. Before you can do 
so, you need to make the Graphics window active: 

� Click on the Graphics window.  

 =

Now the Graphics window is active as you can also see from the display of the Graphs&Geo-
metry Toolbar. 

� Move the label into the third quadrant. Grab the graph, and then move it.  

 = =

Observe how graph, algebra, and numbers change simultaneously. 

� 

Conclude this set of exercises by exiting TI-Nspire. The Exit command can be found in the 
File menu. 

� Exit TI-Nspire using the File>Exit command. 

  
TI-Nspire asks if the yet unnamed document should be saved. 

� To exit without saving select E|kç|F. 

=



Introduction to Interactive Geometry 

This chapter is an introduction to the Geometry application of TI-Nspire. The Geometry appli-
cation is part of the Graphs&Geometry application. This text will get you started. You will 
learn the routine use of this application independent of any other TI-Nspire applications. 

  
� Start TI-Nspire. Move the mouse pointer into the work area, and then click any of the two 

mouse buttons. 

 
� Select Add Graphs&Geometry by clicking the left mouse button on that text line. 

 

This changes the appearance of the work area, which now shows a coordinate system. In the 
bottom line there is a function editor entry line with a blinking cursor in it. Above the work 
area there are ten buttons in the Graphs&Geometry Toolbar. 

The coordinate system indicates that TI-Nspire now is in Graphing mode. Proceed as follows 
to turn it into Geometry mode: 

� Move the mouse pointer over the second toolbar button. 
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The tool tip, which appears for about 3-4 seconds below the pointer indicates that this button 
is the entry into the View menu. (Tool tips are available for all buttons.) 

� Open the View menu by clicking on this button. 

  
Among the many choices in this menu, the second option is for switching into Geometry 
mode. 

� Move the mouse pointer over the command name Plane Geometry View. Click on it. 

  
This changed the work area to an empty page with scale information in the upper right corner. 

In this application you can perform geometric constructions interactively. You can draw 
points, lines, and shapes; you can perform geometric constructions such as drawing parallel 
lines, perpendicular lines, perpendicular bisectors; you can apply tools for reflection, transla-
tion, etc. What you would otherwise do with pencil, ruler, and compass, you can do here with 
a mouse and mouse button. What makes this application superior to any paper and pencil 
environment is that you can move independent objects and all dependent, constructed objects 
follow the movement. This makes a dramatically powerful tool for experimental learning. 

Start with drawing the simplest geometric object, a point: 

� Open the Points&Lines menu by clicking on the button . Click on the Point command. 

 =====  
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kçíÉ the image of the Point button in the upper left corner of the empty page as an indication 
that the Point tool is active and that you can now draw points using the mouse. Such an image 
in the upper left corner means that the respective tool is persistent and remains active until it is 
switched off. The mouse pointer has taken the shape of a pencil. This is also indicated by the 
text ‘point’ that accompanies the pencil. 

� Move the tip of the pencil to where you want to draw a point. Draw the point by clicking 
the left mouse button, and then move the mouse pointer to another location. Draw a 
second point. 

  
The Point tool remains active until you activate a different tool. The Geometry application’s 
neutral tool is the Pointer, which you can find in the Actions 

menu and which also can be activated with the Ebp`F key. 
Therefore the Ebp`F key quits any (other) tool.= 

Delete one of the two points. Deletion is done in two steps. First select the point, and then 
delete it. To select the point or any other object you need the Pointer tool: 

� Turn on the Pointer tool with Ebp`F (or by applying the Actions>Pointer command). 

  
The image of the button in the upper left corner has disappeared (no button image in the upper 
left corner indicates that the Pointer tool is active) and the mouse pointer has the usual shape 
of an arrow. 

� Move the pointer to the upper point. 

 =  
When the pointer is close enough to the point, it takes the shape of a hand, the text ‘point’ 
appears, and the point flashes. This is an indication that the point is ready for selection. 
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� Select the point by clicking the left mouse button. 

  
The point continues to flash and the hand has changed back to an arrow. 

There are three methods for deleting the point (or any other object). You can use the computer 

keyboard’s EabiF key, the Command Toolbar’s Delete button , or the menu command 
Edit>Delete. 

� Delete the point by clicking on the Delete button . 

  
� 

Next draw a line: 

� Open the Points&Lines menu. Select the Line command. 

 =====  
Now an image of the Line button displays in the upper left corner and the pointer has the shape 
of a pencil again. Draw a line by choosing a point and a direction – in this order. This is indi-
cated by the text ‘point’ that accompanies the pencil. So the next thing to do is to draw a point: 

� Choose a location for the point, and then draw it by clicking the left mouse button. Move 
the mouse pointer slightly away from the point. 

 =  
After fixing the point, any movement of the pencil (i.e. the mouse) creates a tentative line, 
which displays dotted. The new position of the pencil gives the line a tentative direction. The 
symbol e indicates that you can select another option by pressing the tabulator key. 
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� Press the tab key EˆF. Press EˆF once more. 

 =  
You can draw a line either by choosing a point and a direction or by choosing two points. Use 
the tab key to select one of these two options. 

� Move the pointer (and with it the tentative direction/line) so that the line has the direction 
you want. Fix the line by clicking the left mouse button. 

 =  
� Move the pointer away from the line. Draw another point, and then move the pointer away 

from this new point. 

  
Because the Line tool is still active, the last two actions started the creation of a new line. As 
long as the drawing of the line is not completed by fixing the direction, you can delete the 
tentative line with Ebp`F. Ebp`F is this application’s standard exit key (one could even say 
“emergency exit” key) and is therefore especially useful for the beginner. 

� Cancel the temporary line with Ebp`F.  Switch off the Line tool with another Ebp`F.  

 =  
The line is actually a finite-length line segment, which is often convenient. If a line is shorter 
than you wish, you can make it longer. If it is longer than you wish, you can make it shorter. 

� Move the pointer to the lower end of the line. 
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The mouse pointer now has the shape of a hand, the text ‘line’ is displayed, and this end of the 
line now has an arrow head. 

� Extend the line: Click and hold the left mouse button, thus “grabbing” the end of the line, 
and then move the mouse down and/or to the right. 

  
Use the same method to make the line shorter if needed. 

What could you do with what you have, i.e. a point and a line? How about reflecting the point 
at the line? 

� Open the Transformations menu by clicking on . Select the Reflection command. 

 ===============  
An image of the Reflection button displays in the upper left corner and the mouse pointer has 
the shape of a pencil. First select the object that you want to reflect, i.e. the point. 

� Point at the point, and then select it by clicking on it. Move the pointer to the line. 

 =  
The selected point flashes. As soon as the pointer touches the line, the line starts flashing too, 
displaying the tentative reflected point. This shows what would happen if you select the line as 
the second argument for the Reflection tool. 

� Perform the reflection by clicking on the line. 

  
It is a good idea to change the appearance of the reflected point so that it looks different from 
the original point. Turn on the Pointer tool, which turns off the Reflection tool, and then point 
at the reflected point: 
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� Switch to the Pointer tool with Ebp`F. Point at the reflected point, and then display a 
menu of possible actions by clicking the right mouse button. 

 =======  
The appearance of the point is controlled via the Attributes command. (Another source for this 
command is the Tools menu.) 

� Click on Attributes. 

  
A graphical menu appears that lets you control the appearance of the point. The current setting 
is  (1/7) Circle , which means that ‘Circle’ is the first out of seven options for the shape of the 
point. Click on the small little triangle at the right to look at the next option. (You could also 
use the right arrow key EÃF.)  

� Look at the second choice by clicking on the small black triangle. Click once more to look 
at the third choice. 

 =  
The second choice is  (2/7) Empty circle , the third choice is  (3/7) Square . Choose the empty 
circle. 

� Go back to the empty circle by clicking the small black triangle on the left or by using 
E‹F. Confirm your choice with the ‘Enter’-key E¿F. 

 =  
(If you exited this menu with Ebp`F, any change is undone.) 

The point, the line, and the reflected point make a geometrical configuration. Every configura-
tion comprises independent and dependent objects. The independent objects are those, for 
which position, size, or shape have been chosen arbitrarily. In the above example the (original) 
point and the line are independent objects. The dependent objects are those, for which posi-
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tion, size, or shape depend on position(s), size(s), or shape(s) of other object(s). In the above 
example the reflected point is dependent. There are also cases in which objects are partly 
dependent, such as a point on a line. 

The Geometry application allows you to move the independent objects and automatically all 
dependent objects are adjusted so that the properties that were enforced during the construc-
tion (such as reflection, incidence, parallelism, etc.), are preserved. For example, a reflected 
point remains a reflected point even if the reflection line or companion point moves. Move the 
point: 

� Make sure that the Pointer tool is active. 
Grab the point, i.e. point at it, and then click and hold the left mouse button. 
With the left mouse button depressed move the mouse and, hence, the point. 

 =  
Observe how both the point and the reflected point move. The grabbed point can move to the 
other side of the line: 

� Move the original point to the other side of the line. 

 =  
Next move the line: 

� Release the mouse button and, hence, the point. 
Point at the line – but not at the point that was used to draw it. 

  
� Grab the line by clicking and holding the left mouse button. 

With the left mouse button depressed move the mouse and, hence, the line. 

 =  
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Observe how the line moves and with it the reflected point. By grabbing the line at a location 
different from the point that was used to draw it, you change the line’s direction. This results 
in a rotation of the line around the line’s defining point. If you grab the line at its defining 
point, and then move it, the line will perform a parallel translation. Do it: 

� Point at the line’s defining point. Press the tab key EˆF. 

 =  
Use the tab key to select either the point or the line. 

� Press the tab key once more in order to select the point. Grab the line at its defining point, 
and then move the line. 

 =  
Finally try to move the empty reflected point: 

� Try grabbing the reflected point: Point at it, and then click and hold the left mouse button. 
Now try to move it. 

 =  
The point does not move. Draw a new line that passes through the point and that is perpendi-
cular to the original line: 

� Open the Construction menu by clicking on . Select the Perpendicular tool. 

 ===  
An image of the Perpendicular button displays in the upper left corner and the mouse pointer 
has the shape of a pencil. 

A line is determined by two points or by a point and a direction. For a perpendicular line you 
need to choose a direction by choosing an object, such as a line, to which the new line shall be 
perpendicular, and you need to choose a point. You can make these two choices in either 
order. 
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� Choose the line by clicking on it, and then move the pointer slightly away from the line. 

 =  
A tentative perpendicular line is shown passing through the tip of the pencil. Next you need a 
point to fix the line. 

� Move the pointer, and with it the tentative line, to the original point. When the point 
flashes, you are right there. Click on it to fix the line. 

 =  
Make the perpendicular line look different from the original line by changing its style to 
‘dashed’. The method to do this is the same as the method you used for changing the appea-
rance of the reflected point. You could display the Attributes menu for the line by pointing at 
the line, clicking the right mouse button to display the context menu, and then choosing the 
Attributes command from this menu. The alternative is to first choose the Attributes command 
from the Actions menu, and then select the object for which you want to change attributes: 

� Invoke the Attributes command from the Actions menu, and then point at the 
perpendicular line. 

 ==========  
� Display the Attributes menu for the line by clicking on the line. 

Change from ‘Line weight’ (first/upper selection field) to ‘Line style’ (second/middle 
selection field) by clicking on the middle square or by applying E¼F. 

 =  
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� Change to ‘dashed’ by clicking twice on the small black triangle on the right. 

  
� Make the new line style permanent by leaving the menu with E¿F. 

 =

 

Before starting with a new construction, delete all objects: 

� Choose the Delete all command from the Actions menu.   

 ===========  
Refrain from deleting all objects with this command so that you can learn a method for 
selecting objects with a crop rectangle. (If you already performed the deletion, undo it by 
using the Undo button or command.) 

� Click on E|kç|F, turn off the Attributes tool with Ebp`F, invoke the Actions>Select 
command, and then move the mouse pointer into the upper left corner for choosing the 
first corner of a crop rectangle.   

 ====  
� Click the left mouse button, and then, without depressing the mouse button, move the 

pointer down and to the right. 
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This will create a dotted crop rectangle with the position you previously chose as the upper 
left corner and the current pointer position as the lower right corner. 

� Make the rectangle big enough so that all objects are within it. (For the original line only 
the defining point must be included.) 

  
� Click the left mouse button to finish selection with the crop rectangle 

  
All objects are flashing, i.e. all objects are selected now. Whatever you do next, you will do it 
to all objects. 

� Delete all (selected) objects by clicking on the Command Toolbar’s button . 

  
All objects are gone. Please note that with this method there is no warning message asking if 
you really want to delete everything. However, you can undo an accidental deletion with the 
Undo command or button. 

� 

Conclude this chapter by exiting TI-Nspire. The Exit command can be found in the File menu. 

� Exit TI-Nspire using the File>Exit command. 

  
TI-Nspire asks if the yet unnamed document should be saved. 

� To exit without saving select E|kç|F. 



Introduction to Lists&Spreadsheet 

This chapter is an introduction to the Lists&Spreadsheet application of TI-Nspire. It will get 
you started, and you will learn the routine use of this application independent of any other TI-
Nspire applications. 

  
� Start TI-Nspire. Move the mouse pointer into the work area, and then click any of the two 

mouse buttons.    

 
� Select Add Lists&Spreadsheet by clicking the left mouse button on that text line. 

 

This changes the appearance of the work area, which now shows a matrix of cells with row 
references starting with 1, column references starting with A. The cell in the first row of the 
Ath column is highlighted as is indicated by the dark rectangle around it. (The highlighted cell 
is the one that will accept an input from the keyboard.) The last line in the work area, which 
has a gray background, shows the address of the highlighted cell: A1. We will refer to this line 
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as the status line. The address of a cell is composed of the label of the column it belongs to 
and the label of the row it belongs to, such as A1 for the cell in column A and row 1. Above 
the work area there are five buttons in the Lists&Spreadsheet Toolbar. 

Enter 1 into cell A1: 

� Type:   1 

  
Typing takes the cell into input mode as is indicated by a blinking text cursor. The number 1, 
which you just typed, is displayed both in the cell (with the text cursor blinking next to it) and 
in the status line. 

� Conclude the input with the ‘Enter’-key E¿F. 

  
Cell A1 now contains the number 1 and the cell below it, cell A2 (see also the address in the 
status line), now is highlighted. 
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� Enter 3 into cell A2 by typing:   3 E¿F  Type ‘7’ into cell A3. Conclude with EˆF. 

 =  
If you conclude an input with the ‘Enter’-key E¿F, the next cell waiting for an input is the 
cell below the current cell. If you conclude an input with the tab-key EˆF, the next cell wai-
ting for an input is the cell right of it. 

When no cell is in input mode, which is started by typing something, you can move the high-
lighting of the cell with the four arrow keys: EÃF for one cell right, E¼F for one cell down, 
E‹F for one cell left, and E½F for one cell up. Make cell B1 active, i.e. the first cell in 
column B: 

� Move the highlighting two cells up with two applications of E½F. 

 = =

Enter the numbers 8, 100, 12, and 5 into the first four cells of column B. An input also can be 
concluded with the up arrow key E½F or the down arrow key E¼F: 

� Type:   8 E¼F Type:   100 E¼F 12 E¼F 5 E¼F  

 = =

Make the cells in the third column, C, be the sums of the respective cells in the first two col-
umns. Because this should be true for all cells of C, you can make this a column definition. To 
enter a column definition, highlight the gray cell between the column label C and the first col-
umn cell, i.e. cell C1. This gray-shaded row is called the � (diamond) row, because it is label-
ed with a ‘�’ at its left end. 
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� Use the arrow keys to highlight the cell in the � (diamond) row of column C. 

 =

Column C should be the sum of columns A and B. Because TI-Nspire does not distinguish 
between upper and lower case letters, this can be entered as follows: 

� Type:   =a+b 

 =

� Conclude the input with E¿F. 

 =

Oops – the result is an error message telling you that the two columns that you wanted to add 
don’t have the same length and therefore the operation cannot be performed. Make the two 
columns equally long by deleting the fourth element of column B. (Alternatively you could 
enter a zero into A4.) Before doing so, get rid of the error message. You could delete the con-
tents of B4 despite the error message, but use this opportunity to learn more about TI-Nspire: 

� Quit the error message by clicking E|lh|F or by applying the ‘Enter’-key E¿F. 

 =

The cells of the third column are all filled with an error message now. 

Use the general Undo command from TI-Nspire’s Command Toolbar to undo the last step, i.e. 
the step that led to the error message: 
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� Click on the Command Toolbar’s Undo button . 

 =

The contents of the cells of column C disappeared, but the definition in the � row is still there 
(as you can also see in the status line). If now you would try to highlight cell B4 as a prepara-
tion for deletion, TI-Nspire would again take the definition for column C and the same error 
message would occur. The Undo button has undone only the very last keystroke, which was 
the ‘Enter’-key with which the column definition was entered. Apply Undo again to take back 
the entire column declaration – key by key: 

�       

 = =

Now you are ready to highlight cell B4 for deletion. You can use the arrow keys or just click 
into the cell: 

� Point at cell B4, and then click the left mouse button. 
Delete the contents of the cell by using the keyboard’s EaÉäF key or the Command 

Toolbar’s Delete button . 

 = = =
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Add the two columns: 

� Highlight the � cell of column C. Type:    =a+b 

 = =

� Conclude the input. 

 =

Assume that you want to make a column wider or smaller. There are two methods for that. 
One method is to use the mouse. 

� In the column label row move the mouse pointer above the vertical line separating 
columns A and B. 

 = =

The mouse pointer turns into a blue vertical bar with a black double-headed arrow perpendicu-
lar to it.  

� Click and hold the left mouse button (this highlights the entire column A), and then move 
the mouse, and with it the column border, to the left. Release the mouse button when 
column A has the desired width. 

 = =

Note the contents of the � cell of column C, which is: ‘=a[]+b[]’. What looks like rectangles 
next to ‘a’ and ‘b’ actually are pairs of square brackets – an opening square bracket and a clo-
sing square bracket with nothing in between. While you can enter a reference to column A by 
simply typing ‘a’, TI-Nspire displays it in standardized notation as ‘a[]’ to avoid potential con-
flicts with objects from other TI-Nspire applications that might have the name ‘a’. 

When a column is highlighted, such as now, applying the left and right arrow keys moves the 
column highlighting to the left or the right column, respectively. 
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� Highlight column B with EÃF. 

 =

You can highlight multiple adjacent columns by combining the arrow key with the shift key 
EŸF. 

� Highlight column A in addition to column B by holding down the shift key EŸF, and then, 
with this key depressed, apply E‹F. 

 =

Highlight column D by clicking on its label: 

� Move the mouse pointer over the column label ‘D’, and then click the left mouse button. 

 = =

Highlight cell A1 … 

� … by clicking into it. 

 =

You can extend the highlighting to neighboring cells using the same technique as with 
columns. Highlight B1 in addition to A1: 

� Press and hold EŸF, and then use EÃF. 

 =
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Extend the highlighting to also include A2 and B2: 

� Press and hold EŸF, and then use E¼F. 

 =

All these selections also can be made with the mouse using the usual click-hold-drag method 
common to most Windows programs. 

Change the value in cell A2: 

� Highlight cell A2. Type:   25 Conclude with E¿F. 

 = = =

Note that the contents of cell C2, which is defined as the sum of (the contents of) cell A2 and 
(the contents of) cell B2, was updated automatically. Every update of a cell causes a complete 
recalculation of the entire matrix of cells. 

Declare column D to hold the first five integer squares. Use the Sequence wizard for this: 

� Highlight the � cell of column D. 

 =

� Open the Data menu by clicking on .  
Invoke the Generate Sequence command by clicking the command name. 

 ====== =

This dialog has four input fields. The first input field, the Formula, and the second input field, 
the Initial Terms, are compulsory. In addition you have to specify either the third input field, 
the maximum number of terms, Max No. Terms (which is pre filled with 255), or the fourth 
input field, the  Ceiling Value. The production of the sequence will stop when it has reached 
the Ceiling Value or when it has as many as Max No. Terms elements, whichever comes first. 
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An expression for generating squares is n². The first square should be the square of 1, there-
fore choose a starting value of 1. Finally change the number of terms from 255 to 5: 

� Type:   n^2 EˆF=  1  EˆF Type:   5 

 == == =

� Conclude the input with E¿F or by clicking on E|lh|F. 

 =

� 

The name of this application, Lists&Spreadsheet, suggests that it has two aspects. So far we 
looked at the aspect belonging to the first part of this name. Technically, each column is a list, 
so what you did was similar to what you can do in a List Editor on a TI-89, TI-92 or Voyage 
200 handheld. Lists can also be used in the other TI-Nspire applications. In other applications 
lists are enclosed within curly braces. Consult the “Introduction to the Calculator” and the 
“Introduction to Combining TI-Nspire Applications” for more.  

� 

The second name of this application, Spreadsheet, suggests that you can use this application 
the same way one uses standard spreadsheet products such as Microsoft™ Excel™. Next learn 
how to use it like a standard spreadsheet. 

� Enter numbers 1, 4, and 7 into the first column, and then highlight cell B1. 

 =
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Define (the contents of) cell B1 to be one more than (the contents of) cell A1.  

� Type:   =a1+1  Conclude with E¿F. 

 == == =

As is customary in standard spreadsheet programs, you could click on cell A1 instead of 
typing ‘a1’.  

This dependency of B1 on A1 can be extended to cells B2 and B3. In other words, the 
definition of B1 can be transferred to B2 and B3. 

� Highlight the cell whose definition you want to transfer, i.e. highlight B1. 

 =

� Open the Data menu, and then select the Fill Down command. 

 = =

This adds a dashed rectangle to the solid rectangle indicating the selection of cell B1. 

� Extend the dashed rectangle to include B2 and B3 by applying E¼F two times. 

 =
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� Conclude with E¿F. 

 =

At first glance it appears as if defining column B to be “column A plus 1”, entered as ‘=a+1’ 
into the �-cell of column B, would have produced the same result. However, the two methods 
are different. A column definition would apply to all cells in the column, i.e. also to cells B4, 
B5, …. The definition transfer you did with the Fill Down command applies only to the cells 
that you chose for the transfer. 

Suppose that you entered a value into cell A4. With a column definition cell B4 automatically 
would be filled according to the column definition. With a cell definition such as above, B4 
would remain empty until you apply the Fill Down command (again) to transfer the definition 
from B3 to B4.  

The Fill Down command has another useful property. Suppose you want to enter the first five 
odd numbers. 

� Enter 1, 3, and 5 into cells C1, C2, and C3, respectively, and then highlight all three cells.  

 = =

� Apply the Data>Fill Down command to extend the definition to the next two cells. 

 = = =

The first three numbers suffice to describe the pattern (of an arithmetic sequence). The differ-
ence between the second and the first number is the same as the difference between the third 
and the second number. The Fill Down command recognizes the pattern and then applies it to 
the following cells. 
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Many built-in functions are available. Proceed as follows to write the arithmetic mean of the 
elements of column A into D1. The function for computing the arithmetic mean is ‘mean’. It 
takes as an argument a range of cells, written as ‘first cell’, then a colon, and then ‘second 
cell’.  

� Highlight D1. Type:   =mean(a1:a3) 

 = =

   =

Cell D1 is too narrow for the entire input string, but you can see its echo in the status line. 

� Conclude the input. 

 =

� 

An alternative to using the Lists&Spreadsheet application’s statistics commands is to use the 
Data&Statistics application, which also offers its own graphical representation features. The 
Lists&Spreadsheet application’s Data>Quick Graph command is a shortcut to producing a data 
plot with the Data&Statistics application. Find out more about this in the “Introduction to 
Data&Statistics”.  

� 

Conclude this chapter by exiting TI-Nspire. The Exit command can be found in the File menu. 

� Exit TI-Nspire using the File>Exit command. 

  
TI-Nspire asks if the yet unnamed document should be saved. 

� To exit without saving select E|kç|F. 



Introduction to Notes 

This chapter is an introduction to using the Notes application of TI-Nspire CAS. It will get 
you started and you will learn the routine use of this application independent of any other TI-
Nspire CAS applications. 

  
� Start TI-Nspire CAS. Move the mouse pointer into the application window, and then click 

any of the two mouse buttons.    

 
� Select Add Notes by clicking the left mouse button on that text line. 

 

This changes the appearance of the application window, which now shows a blinking cursor in 
the upper left corner. Above the application window there are four buttons in the Notes 
Toolbar.    

Start writing:  
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� Type:   This is the Notes application in standard mode. 

  
As with most word processors the ‘Enter’-key starts a new paragraph:  

� Start a new paragraph by pressing the ‘Enter’-key E¿F. 

  
� Enter the following paragraph, finishing with E¿F. 

  
Make the word ‘bold’ bold. Start with highlighting this word. Use standard Windows tech-
niques such as double-clicking for highlighting a word and triple-clicking for highlighting a 
paragraph. 

� Double click on the word ‘bold’. 

  

� Open the Format menu by clicking on . 

  
There are five commands in this menu for formatting text. 

� Make the highlighted word bold by clicking on the command name Bold ( ). 

  
� Remove the highlighting by clicking somewhere else. 

  
Next underline the word ‘underline’: 
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� Highlight the word ‘underline’ by double-clicking it. Underline it by applying the com-

mand Format>Underline ( ), and then remove the highlighting by clicking somewhere 
else. 

  
Note that when you use double-clicking to highlight a word, a comma following the word will 
be highlighted too. Therefore the comma also was underlined. (In fact, in the previous step 
you also made the comma following the word ‘bold’ bold.) Proceed as follows to remove the 
underlining from the comma:  

� Put the cursor next to the comma. 

  
� Highlight the comma with EŸF+E‹F. 

  
The command that you used for underlining is actually a toggle switch, i.e. it lets you toggle 
between underlined and not underlined. The same is true for the other four commands in the 
Format menu. Therefore, remove the underlining from the comma with the command you 
used for underlining it: 

� Apply the command Format>Underline, and then remove the highlighting. 

  
Make the word ‘italics’ italics: 

� Highlight as appropriate, and then use the Format>Italic command. 

  
Turn the three letters ‘sub’ from ‘subscript’ into a subscript and the five letters ‘super’ from 
‘superscript’ into a superscript: 

� Highlight the respective letters, and then apply Format>Subscript and 
Format>Superscript, respectively. 

  

� 
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There are geometric shape symbols for triangles, vectors, etc. available for your texts. Learn 
here how to use them. 

� Put the cursor at the beginning of a potential new paragraph by clicking somewhere in the 
empty space below the text.  

  
� Enter the following paragraph, using E¿F at the end. 

  

� Highlight the letters ABC without the comma. Open the Insert menu by clicking on , 
and then open the Shape submenu. 

  
� Apply the Angle command. 

  
An angle symbol was inserted before ABC. 

� Remove the highlighting with EÃF. 

  
� Put the cursor between ‘B’ and ‘C’. 

  
The Angle command turned the three letters ABC and the angle symbol into a group. When 
the cursor is inside such a group, the group property is indicated by delimiting dotted square 
brackets. 

Apply the above procedure for making RST a triangle, NM a line, and PQ a vector: 

� Use Insert>Shape>Triangle to make RST a triangle. 
Use Insert>Shape>Line to make NM a line. 
Use Insert>Shape>Vector to make PQ a vector. 
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� 

You can enter mathematical expressions the same way you would enter them in the Calculator 
application by using the Expression Box command. This is comparable to using an equation 
editor within a text processing program. 

� Enter the following text, including a space after the colon: 

  
� Apply the Insert>Expression Box command. 

 ==  
As you can see from the menu, E`íêäF+EjF is a hot key for inserting an expression box. An-
other alternative is the context menu that you can open by clicking the right mouse button. 

Within this expression box, which is denoted by a black dashed rectangle within a red dotted 
rectangle, the same rules apply as in the Calculator application. Consult the “Introduction to 
the Calculator” to learn more about how to enter expressions into an Expression Box.  

Enter the expression 43 sin( / 4)π+ : 

� Type ‘3’ followed by the exponentiation operator ’^’ followed by ‘4’. 

  
The exponentiation operator switched on exponentiation/superscript mode. 

� Type:   + 

  
Oops! We don’t want the plus operator to be in the exponent. Delete it, exit the exponentia-
tion/superscript mode with the right arrow key or the tab-key, and then continue entering the 
expression. 

� Delete the plus symbol with the backspace key E‹|F, and then use the right arrow key 
EÃF to exit exponentiation mode. 

  
� Type:   +sin 

 =  
Within an expression box variables are displayed in italics. Built-in and user-defined functions 
are recognized automatically and they are not displayed in italics so that they can be more 
easily distinguished from variables. Therefore ‘si’ was in italics until the letter ‘n’ was added. 
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� Type an opening parenthesis:   ( 

  
A closing parenthesis was included automatically. 

Next you need a source for the symbol for pi. Pi can be obtained from the Symbols Toolbar, 

which is accessed via the Command Toolbar’s button . You could also simply write ‘pi’. 

� Display the Symbols Toolbar by clicking on . 

  
� Insert pi by clicking on the button  in the upper left corner. 

  
� Type:   /4 

  
� Use the right arrow key (or type a closing parenthesis) to get to the end of the expression. 

  
� Exit the expression box with another application of the right arrow key. (You can also exit 

an expression box with Ebp`F.) 

  
The red dotted rectangle has disappeared. Now cursor control again is within normal text. 

An expression box can be evaluated. 

� Highlight the expression box. 

  
Make sure the entire box is highlighted, otherwise only the highlighted portion will be evalu-
ated. 

� Open the Actions menu by clicking on . 

  
The first command evaluates the highlighted (sub-)expression. 

� Choose the Evaluate Selection command. 
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The result of the evaluation replaced the original expression. If you want to see both, i.e. the 
expression and the result, then you should make a copy of the expression before evaluating it. 
Do it: 

� Undo the evaluation by clicking the Command Toolbar’s Undo button . 
Copy the (highlighted) expression box into the clipboard with Edit>Copy. 

  
� Click right of the expression box to remove the highlighting. 

  
The red dotted rectangle around the expression is still there, so obviously the cursor is still 
inside the expression box. You need to exit the expression box: 

� Exit the expression box with Ebp`F. 

  
� Type an equal sign, ‘=’, and then paste a copy of the expression box with Edit>Paste. 

  
Evaluate the copy of the expression box, this time without highlighting the expression. It 
suffices for the cursor to be within the expression box, as is indicated by the red rectangle. 

� Apply the Actions>Evaluate Selection command. 

  
The Evaluate Selection command also can evaluate selections outside an expression box. 

� Enter a new paragraph with the following text: 

  
� Highlight ‘1+3^4’, … 

  
� … and then apply the Actions>Evaluate Selection command. 

  

� 

Conclude this chapter by exiting TI-Nspire. The Exit command can be found in the File menu. 

� Exit TI-Nspire using the File>Exit command. 
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Introduction to Data & Statistics 

This chapter is an introduction to the Data&Statistics application of TI-Nspire. It will get you 
started and you will learn the routine use of this application. 

  
� Start TI-Nspire. Move the mouse pointer into the work area, and then click any of the two 

mouse buttons.  

 
� Select Add Data&Statistics by clicking the left mouse button on that text line. 

 

This changes the appearance of the work area, which now shows an empty page with a hori-
zontal axis and a vertical axis, both of them with an invitation to ‘Click to add variable’, and 
the text ‘No lists in this problem’ in the center of the page. Above the work area there are four 
buttons that together make the Data&Statistics Toolbar. 

� Click at the vertical axis’ text ‘Click to add variable’. 

 <none> 
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A selection menu appears with the (low contrast) text ‘<none>’ as an indication that there is 
no data available. 

Data for the Data&Statistics application must be generated by another application. The Data& 
Statistics application requires data in form of lists, therefore the “most natural” companion 
application is the Lists&Spreadsheet application. Therefore consult the “Introduction to 
Lists&Spreadsheet” before proceeding further in this Data&Statistics chapter. 

Undo the introduction of a Data&Statistics application and start with a Lists&Spreadsheet 
application instead. Enter a data set, and then use the Lists&Spreadsheet Quick Graph 
command to add a Data&Statistics window: 

� Apply the Undo button , and then insert a Lists&Spreadsheet application. 

=  

Enter the following sample data: 

� Enter into column A:   1 E¿F 2 E¿F 3 E¿F 4 E¿F 5 EˆF 
Enter into column B:   2 E¿F 3 E¿F 2 E¿F 8 E¿F 9 E¿F 

  
Produce a scatter plot of this data set: 

� Open the Data menu, and then invoke the Quick Graph command. 

  
The Quick Graph command is dimmed. It is only available when the column has a name. The 
column labels A and B do not suffice for this purpose. Use names ‘ca’ and ‘cb’: 
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� Exit with Ebp`F. 
Click into the name field of column A, and then type:  ca EˆF=

 = ====  
� Enter, into the name field of column B, the name:  cb 

 =  
� Highlight B1, and then invoke the Data>Quick Graph command. 

  
The work area now is split into two halves, one for the spreadsheet and one for graphics, 
which, in fact, is the Data&Statistics application. The Data&Statistics window contains a dot 
plot of the data from column cb, as you can see from the column name, cb, below the horizon-
tal axis. The reason it used cb is, that a cell from cb was highlighted when the Quick Graph 
command was invoked. The Lists&Spreadsheet Toolbar was replaced by the Data&Statistics 
Toolbar. You can switch between these two windows by clicking into the one you want to 
make active. The active window has a darker border. 

� Make the spreadsheet active by clicking into the left window. 
Change back to the Data&Statistics application by clicking into the right window. 

 =  
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There are alternative options for displaying the data of column B/cb. Find these alternatives in 
the Plot Type menu: 

� Open the Plot Type menu by clicking on . Invoke the Box Plot command. 

 ===========  
� Next try Plot Type>Histogram. Finally go back to Plot Type>Dot Plot. 

 =  
You can change the scale of the plot with the mouse. Grab the axis, and then move it: 

� Move the mouse pointer to the left end of the horizontal axis until it turns into a blue 
vertical bar with a double-headed arrow perpendicular to it. Click and hold the left mouse 
button. With the mouse button depressed, drag the axis slightly to the right.  

 =  
This changes the scale factor. Similarly you could grab the right end of the horizontal axis and 
move it. You can also shift the axis without changing the scale: 

� Move the mouse pointer to the center of the horizontal axis until it turns into a four-
headed arrow. Click and hold the left mouse button. With the mouse button depressed, 
drag the axis slightly to the left.   

 =  
This performed a horizontal shift of the graph. You also can grab and move points: 
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� Point at the rightmost point.                    Click on it, and then hold the (left) mouse button. 

 =  
Clicking on the point changed its color from gray to red. Holding the mouse button depressed 
displays the numeric value that this point represents. 

� Grab the point, and then move it to the left. 

  
The value changes as the point takes a new position – and this change is also performed in the 
respective spreadsheet cell. 

You can select and move groups of points. Add a point to your selection by clicking on it: 

� Click on the now rightmost point. Move it to the right. 

  
Both points are red now and both points move (in parallel). The changes are also reflected in 
the spreadsheet. 

� Unselect both (i.e. all) points by clicking into ‘empty space’. 

  
Now all five points are gray again. You can display the value (coordinate) of any position 
along the axis by clicking and holding the left mouse button. 

� Click and hold the left mouse button where there is no point. 

  
� 
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Make a restart so that you can produce the scatter plot: 

� Open the Plot Properties menu. Select the Clear All command. 

 =====  
The data points that you now see in the right window are a graphic representation of the first 
component (‘Caption: Ca’) of the five data sets – but without reference to a coordinate system. 
The two text lines ‘Click to add variable’ indicate that you may select data for the two axes. 

� Click on the text ‘Click to add variable’ below the horizontal axis. 

  
A selection menu displays with all lists currently available in TI-Nspire. 

� Choose ca. 

 =  
This is a dot plot of the values in column ca (= column A). 

� Move the mouse left of the vertical axis (until a rectangle appears). Click the left mouse 
button to display the selection menu, and then choose cb from there. 

 =  
This is a scatter plot of the data in columns ca and cb. 

Conclude this chapter by exiting TI-Nspire. The Exit command can be found in the File menu. 

� Exit TI-Nspire using the File>Exit command. 



Introduction to Combining  
TI-Nspire CAS Applications – Part 1 

This and the next chapter are an introduction to combining applications of TI-Nspire CAS. 
The seamless integration of key technologies such as computer algebra, graphing, interactive 
geometry, and spreadsheet technology is one of the major strengths of TI-Nspire CAS. The 
individual technologies have been on the market for many years and have been tested exten-
sively in the classroom. A lot of literature is available on that and for each of these technolo-
gies there is strong evidence that their proper integration into teaching and learning is benefi-
cial for students. TI-Nspire CAS integrates all of these technologies into a powerful mathema-
tics teaching and learning environment. This integration of well established technologies into 
one tool is a quantum leap and takes us into a new dimension of supporting students in under-
standing and learning mathematics. 

This text will get you started and you will learn the routine use of combining the power of the 
individual applications of TI-Nspire CAS. It is assumed that you are familiar with using each 
individual application to the extent explained in the chapters “Introduction to the Calculator”, 
“Introduction to Graphing”, “Introduction to Interactive Geometry”, and “Introduction to 
Lists& Spreadsheet”. 

 

Basics 

  
� Start TI-Nspire CAS. 

 

A page can be split into up to four subpages. Use the Insert>Layout command for this, which 
opens a submenu with a total of eight options. Look at these options: 
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� Invoke Insert>Layout. 

 

The first choice, a full page, is dimmed, because the current page is a full (i.e. unsplit) page. 
The next two options are a vertical and a horizontal split into two subpages. The next four 
options are different splits into three subpages. The last option is a split into four subpages. 

� Perform a left-right split into two subpages by choosing the second option .  

  
Make the left half a Calculator page and the right half a Graphing page: 

� Click into the left half, and then choose Add Calculator. 
Click into the right half, and then choose Add Graphs&Geometry.   

 =  
In the Graphing window’s entry line define f1 as 2x : 

� Click into the function editor entry line, and then enter:   x^2   

 =  
Look at f1in the Calculator: 
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� Make the Calculator window active, and then enter:   f1(x)   

 =  
Use the Calculator to define function f2: 

� In the Calculator enter:   f2(x):=x+10   

  
� Make the Graphing window active by clicking into it. 

  
� Scroll to f2 with E½F. 

  
The text cursor at the expression’s end indicates that you can edit the expression – or you can 
enter it for plotting: 

� Plot the graph of f2 by pressing E¿F. 

  
Currently each of the two applications uses exactly half of the work area. This can be changed 
by moving the line separating the two windows. 

� Move the mouse pointer above the window separation line until the pointer turns into a 
blue vertical bar with a black double-headed arrow perpendicular to it. Click and hold the 
left mouse button, and then move the mouse and with it the separation line to the left. 

 =  
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� 

Look at the preview pane and learn what you can do there: 

� Select the one (and only) page by clicking on it. 

  
In the preview pane the selection of a page is indicated by a blue rectangle around the page. 

� Copy the selected page into the clipboard with E`íêäF+E`F, and then paste it with 
E`íêäF+EsF. 

  
This doubled the page. You can apply this technique to “freeze” the current state of a page as a 
backup before you use one of the two copies to do more investigations. If you are happy with 
the result of the experiments, delete the backup copy. Otherwise delete the experimental copy. 

Currently the focus is in the preview pane. Here you can select a page by clicking on it. But 
you don’t have to be in the preview pane for changing pages. If focus is in the work area, the 

buttons  and =or the=key combinations E`íêäF+EÃF and E`íêäF+E‹F let you change to 
the next and the previous page, respectively. 

You can collapse and expand the page preview for a problem by clicking on ‘Problem n’ or 
by using the commands View>Collapse All and View>Expand All, respectively.   

� Double click on ‘Problem 1’. Double click on ‘Problem 1’. 

 =  
Delete either copy of your duplicate pages: 
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 � Click on the upper page, and then click on the Command Toolbar’s button  to delete it. 

  
� 

Now you have one page comprising two applications. Suppose you want to have a full page 
for each application. This can be achieved as follows: 

� Make the Calculator window active by clicking into it, and then invoke the Edit>Select 
Application command. 

  
The black frame around the Calculator window should be flashing now to indicate selection. 

� Cut the calculator application with the Edit>Cut command (or with E`íêäF+EuF).  

  
The entire Calculator page content now is in the clipboard. 

� Remove the page split: Open the View>Layout submenu. Choose the first option from 
there, . 
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� Insert an empty page using the Insert>Page command. 
Insert the Calculator contents with the Edit>Paste command (or with E`íêäF+EsF). 

 =  
Now you have two pages, one for each application.  

Next define f3 in the Calculator page: 

� In the Calculator enter:   define f3(x)=5sin(x) 

  
� 

Learn next how to combine two separate pages into one page that is split into two subpages. 
Start by cutting the Calculator page into the clipboard: 

� Select the Calculator application with Edit>Select Application. 
Cut the Calculator application with Edit>Cut (E`íêäF+EuF). 

 =  
� Make the Graphing page active by clicking on it in the preview pane. 

Split the page horizontally by applying Insert>Layout, and then choosing the third option, 
which is . 

 =  



Quick Start Guide – TI-Nspire CAS Software 89 

� Click into the empty lower half, and then paste the Calculator application with Edit>Paste. 

 =  
� 

You can swap applications within a split page: 

� Make the Calculator window active. Apply the Edit>Swap Applications command. Move 
the (now) -shaped cursor into the other window half, and then perform the swap by 
clicking the left mouse button. 

 =  
Finally plot f3: 

� Click into the function editor entry line. Go to f3 with E½F. 

 =  
� Plot f3 by pressing E¿F. 

  
� 

Within a problem all pages share the data. A definition made in any application applies to all 
other applications in all pages within the problem. 

The most flexible application for making definitions is the Calculator. There you can define 
instances of all the data types that are available in TI-Nspire CAS. The least flexible applica-
tion for defining and processing data is the Lists&Spreadsheet application. 

The columns of a Lists&Spreadsheet page are lists, which in the Calculator you would enter 
using curly braces (such as ‘{1,2,3,4,5}’). Each element of a column, called a cell, can contain 
a number, a variable, or an expression composed from numbers, variables, and functions (such 
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as x+5+sin(y)). Simple assignments such as a:=5 are allowed. Lists and matrices cannot be cell 
objects. 

� Insert a new Calculator page, and then make the following three assignments. 

  
aa is a list, so this can easily go into a column of a Lists&Spreadsheet page: 

� Insert a new Lists&Spreadsheet page. Type into the definition cell of column A:   =aa 

  
� Conclude the input with E¿F. 

  
Enter the second list that was defined in the Calculator, a, into the second column: 

� Enter into the definition cell of column B:   =a 

  
There is a conflict with your input ‘a’. Globally, i.e. within the problem, ‘a’ denotes a vari-
able, which contains the list {1,3,5,7,9}. Locally, i.e. within the Lists&Spreadsheet page, ‘a’ 
denotes the first column, which now contains the list {1,2,3,4,5}. The dialog requests you to 
choose between one of these two meanings of ‘a’. Choose the global version: 



Quick Start Guide – TI-Nspire CAS Software 91 

� Open the selection menu, and then choose Variable Reference. Leave the dialog with 
E|lh|F. 

 ==  
See what happens if you make the other choice: 

� Enter into the definition field of column C:   =a 

In the Conflict Detected dialog choose Column Reference. 

 ==  
This copied the contents of column A into column C. Note the difference in the displays of the 
column definitions in the � row. The apostrophe in front of ‘a’ in the definition cell of column 
B identifies this as a variable reference. The pair of (opening and closing) square brackets after 
‘a’ in the definition cell of column C identifies this as a column reference. To avoid the 
Conflict Detected dialog, you can use an apostrophe or square brackets when entering an 
expression in a spreadsheet.  

There is a similar issue with cell definitions. Define D1 to be the same as A2: 

� Highlight cell D1, and then enter:   =a2 

 =  
Define D2 to be the same as A5: 

� Highlight cell D2, and then enter:   =a5 

 =============  
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Now there is another conflict, because earlier you defined a variable a5 in the Calculator. 
Therefore this dialog requests you to choose between a cell reference and a variable reference.  

� Choose Cell Reference.  

  
� Enter, into D3:   =a5 Choose Variable Reference. 

 =  
Look at the definitions of cells D2 and D3 by highlighting the cells, one after the other, and 
looking into the status line.  

� Highlight D2. Highlight D3. 

 =  
Note the use of the apostrophe again to distinguish the variable reference from the cell 
reference.  

� 

In the Notes application you can make all definitions that you can make in the Calculator. Just 
open an Expression Box, enter the definition, and then evaluate it. 

� Insert a new Notes page, and then apply the Insert>Math Expression Box command. 
Enter:   define ff(x)=x+sin(x) 

  
Make sure that the cursor is within the expression box as is indicated by the red rectangle,  … 

� … and then perform the Actions>Evaluate command. 

  
Note that the function name ff changed to bold, because now this is a user-defined function 
name. Check the availability of this new function in the Calculator: 

� Make the Calculator page active, and then enter:   ff(x) 

  
� 
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The Graphs&Geometry application has a function editor for entering and editing functions. 
Using the colon separator you can perform the following trick for using the function editor 
entry line for entering any statements or commands. Perform a dummy function definition, for 
example by defining the next function, f4, to be ‘false’, and then add a colon followed by, for 
example, an assignment of a list to a variable. (Remember that the colon separator is used in 
the Calculator to make several inputs in one line.) 

� Insert a new Graphs&Geometry page, and then type ‘false : aaa:={1,1,2,3,5}’. 

  
� Conclude the input. 

  
Check if list aaa is available in the calculator: 

� Change into the Calculator page, and then enter:   aaa 

  
This trick may be useful if you want to produce a scatter plot, for which you need lists of num-
bers, and you don’t want to open a Calculator page to define them. 

� 

You can make assignments in a text box. Typically, this technique is used to store a measure-
ment done in the Graphing or Geometry window in a variable so that it can be used in other 
applications. 

� Make the Graphing page active, and then draw two points. 

  
� Use Measurement>Length to measure the distance between these two points. 

  
� Turn on the Pointer tool, and then select the measurement. 
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� Prepare for storing this measurement in a variable by using the Tools>Variables command 

or clicking on the Variables button . 

  
� Choose Store Var. 

  
The text box with the measurement now shows an assignment operation with a suggested 
variable name var. Change the variable name to bb: 

� Type:   bb Conclude with E¿F. 

 =  
Check if bb is available in the calculator: 

� Change into the Calculator page, and then enter:   bb 

  
Moving one of the two points will change the distance between the two points. 

� Change into the Graphing page. Grab a point, and then move it. 

  
� In the Calculator page enter:   bb 

  
You can also do it the other way round, so that a value saved in the Calculator controls a 
length in the Graphing or Geometry window. 

� Change into the Graphing page, and then draw a ray. 

  
� Put a number into a text box, … 

  
� … and then transfer it onto the ray using the Construction>Measurement Transfer 

command. 

 =  
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Next define a variable in the Calculator: 

� Change into the Calculator page, and then enter:   contr:=2 

  
Link the number in the Graphing window to this variable: 

� In the Graphing page turn on the Pointer tool, and then select the number. 

  

� Click on the Variables button , open the Link To submenu, and then select contr.  

 =  
The number in the text box was changed to the value that you assigned to contr in the 
Calculator. 

� In the Calculator page change the value of contr by entering:   contr:=9 

  
� Look at the effect of this in the Graphing page.  

  
Conclude this first round of examples by exiting TI-Nspire: 

� Exit TI-Nspire without saving. 

� 

 

Calculator & Graphing  
At the end of the “Introduction to the Calculator” you computed a linear regression without 
being able to visualize the result. Learn here how to use the Graphing application to overcome 
this. 

� Start TI-Nspire CAS, add a Calculator page, and then enter a list of x-values and a list of 
y-values as shown in the picture. 

 

Compute a linear regression for this data set: 
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� Apply Statistics>Stat Calculations>Linear Regression (mx+b). 
In the Linear Regression dialog choose listx for X List and listy for Y List. 

= =  

Note that the third input field, Save RegEqn to, specifies where the resulting regression line 
will be saved. The dialog automatically suggests the next available function from the 
Graphing application’s function editor. Here it is f1. 

� Leave the dialog with E|lh|F. 

 

Produce a graphic representation of the data set and the regression line: 

� Add a Graphs&Geometry page, and then prepare for entering a scatter plot by applying 
the Graph Type>Scatter Plot command. 

 

The function editor entry line for scatter plots offers two selection menus – one for the vertical 
coordinate x and one for the vertical coordinate y. 
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� Open the selection menu for x. 

 

The menu lists all variables that qualify as an input for a scatter plot, i.e. all lists. listx and listy 
are the two lists you entered. The four lists starting with ‘stat.’ were produced by the calcula-
tion of the regression line. They contain statistical information about the data set you used. 

� Choose listx for x and listy for y. Apply Window>Zoom – Data. 

=  

The first point is not visible, because it is behind the entry line. You would need to turn off the 
entry line (remember the hot key E`íêäF+EdF) so that you can see it. Use the Zoom – Box 
command to have more control over choosing a new setting for the window: 

� Go back by using the Undo button .  
Apply Window>Zoom – Box, and then choose an appropriate crop rectangle. 

=  

Remember that the main result of the Linear Regression command, the equation of the linear 
regression line, was stored in f1.  This makes it easily available for plotting. Because it is a 
function, you have to switch back to Function graphing mode: 

� Apply Graph Type>Function. 
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� Scroll to f1 with E½F. 

 
� Plot the graph of f1 with E¿F. 

=  

That is a satisfactory fit for many purposes, but the points have one convex and one concave 
portion, which suggests trying a cubic regression.  

� Exit TI-Nspire without saving the document. 

� 

 

Calculator & Spreadsheet  
The availability of Calculator features makes the spreadsheet a “symbolic spreadsheet” with 
mathematics capabilities that go beyond those of typical business-oriented spreadsheet pro-
grams.   

Much of mathematics is the science of patterns. Create a spreadsheet that experimentally  
reveals patterns of differentiation for discovery.  

� Open a Lists&Spreadsheet page, and then make the second column as wide as possible. 

=  

Define the second column to be the derivative of the first column with respect to x: 

� After entering the equal sign, paste the derivative template, and then choose ‘x’ as the 
variable and column ‘a’ as the expression. 

 

 
Observe your input in the status line. The �-row does not adjust to the expression’s height.   
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� Conclude the input. 

 

You are ready now to make a nice pattern recognition exercise with your students. The goal 
should be not too ambitious, but not too easy either. To start with, let them find the rule for the 
derivative of the n-th power of x by showing them some examples: 

� Enter into the first column the expressions 2x , 5x , and 9x . 

 

Ask your students if they see a pattern and let them describe their findings. You may want to 
add another example if needed: 

� Enter 25x  into the first column. 

 

Probably your students will have the correct answer by now. But you should not make it that 
easy for them. Challenge them by entering a negative power of x: 

� Enter 4x−  into the first column. 

 

At first glance this seems to not fit the pattern. Let your students recollect what they now 

about powers. If needed, help them remember 5
5

1
x

x
−= . Give them a fractional power: 

� Enter 
4

3x
−

 into the first column. 

 

Next challenge them with a fractional power for which TI-Nspire uses a special notation: 

� Enter 
1

2x  into the first column. 

 

Again, this seems to not fit the pattern. But probably, encouraged by the previous examples, 
your students will look for ways to rewrite the expression appropriately. If needed, help them 

remember 
1

2x x= . Finally challenge them with the “hidden” first power of x: 
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� Enter x into the first column. 

 

As simple as this looks, this may be the hardest challenge, aiming at remembering 1x x=  and 

01 x= . At the end of this exercise your students have discovered the rule 1n nd
x n x

dx
−= ⋅  and 

they have reinforced some important facts about powers.  

� Exit TI-Nspire without saving the document. 

� 

 
Geometry and Lists&Spreadsheet  
In the Geometry application you can measure lengths, areas, slopes, angles, and integrals. By 
linking a measurement to a variable, one can use the measurement in other applications. The 
dynamic aspect of the geometry application, i.e. the ability to move objects, let you create 
sequences of measurements stored into lists. The Lists&Spreadsheet application is the ideal 
place for producing such lists. 

� Start TI-Nspire, add a Graphs&Geometry page, and then switch to Plane Geometry View. 
Split the screen, and then add a Lists&Spreadsheet application. 

=  
� Draw a ray, and then define a point on it. 

=  
� Measure the distance of the point to the ray’s starting point.  

 

Link the measured length to a variable so that you can use it in other applications: 
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� Turn on the Pointer tool, and then select the measurement. Apply the Variables command 

by clicking on . 

=  
� Choose Store Var. Change the suggested variable name ‘var’ to ‘len’. 

=  

 

Prepare for collecting the length in the Lists&Spreadsheet application: 

� In the Lists&Spreadsheet application highlight a cell in column A, and then invoke the 
Data>Data Capture>Automated Data Capture command.  

=  

=  

Column A is too narrow for you to see the automatically generated input string in the 
column’s � cell, but you can see its echo in the status line. In the � cell, the template variable 
is highlighted, so that you can type the name that you want. 

� Enter ‘len’, and then make column A wider. 

 

The current value of len was copied into cell A1, all remaining cells of column A remain 
empty. 

� Grab the point on the ray, and then move it to the right, so that you increase the distance 
to the ray’s starting point. 
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Observe how your movement of the point generates new values in column A. The sampling 
rate is rather fast, so extensive movements put many numbers into column A. 

If you want to have explicit control over which measurements enter the spreadsheet, you need 
to do a manual data collection as follows: 

� Highlight the definition of column A. 

 
� Invoke the Data>Data Capture>Manual Data Capture command. 

 

� Enter:   len 

 

This warning message is displayed, because the column contains data from the automatic data 
collection. Answer “yes” by … 

� … clicking on E|lh|F. 

 

Now you have full control over sending data from the Geometry application to the spreadsheet 
– even for the first value. 

� Perform a manual data collection by pressing E`íêäF+EKF. 

 
� Move the point and then collect the new value with E`íêäF+EKF. 

 
� Exit TI-Nspire. 
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Data Collection 
A great TI-Nspire feature is the support of collecting real world data. More than 30 different 
sensors are supported in the current version. Find a list of these sensors at the end of this 
chapter. In the sequel we use the Vernier Go!Temp temperature sensor. If you have this sensor 
available, you can perform the following exercise. If you have another one of the compatible 
sensors, you can perform the following exercise “in principle” by collecting a different kind of 
data. If you do not (yet) have a compatible sensor, reading the text and looking at the screen 
images may make you buy one so that you can do your own data collection experiments. 

� Start TI-Nspire. 

 
� Connect Go!Temp to your computer’s USB socket. 

 

TI-Nspire detects the temperature sensor and offers to launch the data collection console in 
conjunction with one of the three suitable applications (Data&Statistics, Lists&Spreadsheet, 
Graphs&Geometry) – or to start the data collection console alone. 
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� Choose Data&Statistics by clicking E|lh|F. 

 

An empty Data&Statistics page is displayed with the data collection console in the upper right 
corner showing the current temperature. The data collection console offers a green start button 

K 

� Start collecting data by clicking on the green Start button . After a while rub the probe 
or put it into a warm liquid. 

=  

� Stop collecting data by clicking on the red Stop button . 

 

After finishing data collection, both axes will be updated so that the data points fill the screen. 
Move the data collection console into the upper left corner.  
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� Grab the console (somewhere in the dark grey area), and then move it to the left. 

=  

The two axes are labelled with dc01.time and dc01.temp1. These are the names of the lists 
that currently contain the numeric data. 

� Open the View menu ( ), and then invoke the Small command. 

=============  

This minimizes the data collection console and is equivalent to clicking the same looking 
button under the button for closing the display. 

Start a new data collection by clicking the Start button  or via the Experiment menu: 

� Open the Experiment menu ( ), and then invoke the Start Collection command. 

=============  

This warning indicates that new data would overwrite the currently displayed data. Therefore 
you need to decide whether to store or discard the existing data. If you choose E|píçêÉ|F, 
then the time data will be stored in list dc01.time while the temperature data will be stored in 
list dc01.temp1. TI-Nspire uses two new lists for the next run. 
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� Store the previously collected data by clicking E|píçêÉ|F. 

 
� Start the new collection by clicking E|lh|F. Stop after a few seconds. 

=  

As you can see from the labels of the two axes, lists dc02.time and dc02.temp1 are ready for 
holding the new data. 

� Close the data collection console by clicking the corresponding button in the console’s 
upper right corner. Insert the console again using the Insert>Data Collection command (a 
hot key for this is E`íêäF+EaF). 

=======  

Start a new experiment: 
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� Invoke the command Experiment>New Experiment. 

===============================  

Attention! In this message “unsaved data” means the entire document – and not just the data 
that you collected in the previous data collection run. If you choose the exit E|aáëÅ~êÇ|F, 
then also the previously stored lists dc01.time and dc01.temp1 will be deleted. 

� Click on E|aáëÅ~êÇ|F. 

 

Deletion of all data is indicated by the fact that both axes again are labelled with dc01.time 
and dc01.temp1. 

� Exit TI-Nspire. 

� 

 

It follows a list of those 34 sensors from Vernier that can be used with TI-Nspire technology. 
Obtain more information about these sensors at www.vernier.com.  

 

Two sensors can be connected directly to a computer: 

• Go!Temp (for measuring temperature) 

• Go!Motion (for measuring motion) 

Both sensors have a USB interface. 

 

The following sensors can be connected to a computer using the  

• Go!Link 

adapter. This adapter has a BTA socket and a USB plug. In parentheses are the Vernier order 
codes. 
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• 25-g Accelerometer (ACC-BTA) 

• Low-g Accelerometer (LGA-BTA) 

• Barometer (BAR-BTA) 

• Charge Sensor (CRG-BTA) 

• Colorimeter (COL-BTA) 

• Conductivity Probe (CON-BTA) 

• Current Probe (DCP-BTA) 

• Differential Voltage Probe (DVP-BTA) 

• Dual Range Force Sensor (DFS-BTA) 

• Electrode Amplifier (EA-BTA) 

• EKG Sensor (EKG-BTA) 

• Extra Long Temperature Probe (TPL-BTA) 

• Flow Rate Sensor (FLO-BTA) 

• Force Plate (FP-BTA) 

• Gas Pressure Sensor (GPS-BTA) 

• Hand Dynamometer (HD-BTA) 

• Infrared Temperature (IRT-BTA) 

• Light Sensor (LS-BTA) 

• TI Light Probe (LITL-BTA) 

• Magnetic Field Sensor (MG-BTA) 

• O2 Gas Sensor (O2-BTA) 

• pH Sensor (PH-BTA) 

• Relative Humidity Sensor (RH-BTA) 

• Salinity Sensor (SAL-BTA) 

• Sound Level Meter (SLM-BTA) 

• Stainless Steel Temperature Probe (TMP-BTA) 

• Surface Temperature Sensor (STS-BTA) 

• Thermocouple (TCA-BTA) 

• Turbidity Sensor (TRB-BTA) 

• UVA Sensor (UVA-BTA) 

• UVB Sensor (UVB-BTA) 

• Voltage Probe (VP-BTA) 

=



Factory Default TI-Nspire CAS 

Here are instructions about how to restore near-factory default TI-Nspire CAS. In case the 
version of TI-Nspire CAS you are using with this book was used before or is likely to have 
been used before, it is recommended that you follow these instructions before you start going 
through this book. 

Start TI-Nspire CAS by double clicking on the TI-Nspire CAS icon. If there is no such icon on 
your computer’s desktop or task bar, you probably will find TI-Nspire CAS on the Start menu 
at the lower left corner of the screen or via Start>All Programs in the TI Tools folder accessed 
from Windows Explorer. 

�    

� Prepare to open the File menu by moving the mouse pointer above the Menu Bar’s File 
command. 

= =

� Open the File menu by clicking the left mouse button. 

= =

This menu offers several commands. Note the Settings command near the bottom of the 
menu. 
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� Invoke this command by moving the mouse pointer above the command name Settings. 

= =

This opens the submenu. Observe the Document Settings command. 

� Select this command by moving the mouse pointer over the text Document Settings. 

= =

� Invoke the command by clicking on it with the left mouse button. 

= =
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� Move the mouse pointer over the button E|oÉëÉí|íç|aÉÑ~ìäíë|F. 

= =

� Click the left mouse button to activate this command. 

= =

� Confirm that you want to proceed by exiting this dialog with E|lh|F. 

� Move the mouse pointer above the button E|^ééäó|íç|póëíÉã|F. 

= =

� Click the left mouse button to activate this command. 

= =

� Confirm that you want to proceed by exiting this dialog with E|lh|F. 

= =

Now you have an almost factory default TI-Nspire. If former users have used the Catalog, then 
the entry which they highlighted will still be highlighted. This and similar cases will still be 
different from a full factory default TI-Nspire. 

 




